01 Excursion grimlens - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-17-2014, 06:52 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Henderson, NV
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
01 Excursion grimlens

I just picked up a 2001 Excursion, and had a few issues I wanted to run by you guys. Wondering if they're common problems and quite possibly have common fixes.

First issue is the power door locks, when I hit the button I hear all of the actuators actuate. But none of the lock tabs move up or down in the door panels. They seem like they try but don't actually move enough to lock/unlock the door.

The next issue is the parking sensors don't work. The button on the dash to turn them off is illuminated for OFF. If I push the button it quickly flashes, then goes right back to off. Seems like a fault of some sort...I'm kind of lost here. I have parking sensors on my 03 6.0 and they're nice to have, but I have no idea why these ones don't work.

Next issue is my lift gate doesn't lock at all. Power door lock button won't lock it, and the key won't lock it. I can insert the key and turn the cylinder to lock it. But it will never actually lock. I'm guessing I need to dig into the lift gate to figure this one out, any tips or tricks?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-17-2014, 08:36 PM
Compression Ignition Addict
 

Join Date: Jan 2010
Posts: 389
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I have a same lock problem but, only with the driver side rear door. I am just living with it for now. The rear lift-gate lock problem was discussed here a while back. I believe the person removed the interior panel and only required the linkage to be lubricated to make functional. What kind of mileage to do get from the V10?? I get 16 - 18 depending on driving/warm-up.
Reply With Quote Quick reply to this message
  #3  
Old 01-17-2014, 10:31 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Henderson, NV
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the reply, I'll do a quick search for the rear gate info, hopefully I can find it.

I honestly don't know what kind of mileage the V10 gets, it came with half a tank in AZ when I bought it and it's still got over a quarter tank left from the drive back to NV.

I hear they get about 8-10mpg
Reply With Quote Quick reply to this message
  #4  
Old 01-17-2014, 11:04 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Henderson, NV
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Found threads with the rear lock info-
rear hatch lock not working

Locking rear door/hatch
Reply With Quote Quick reply to this message
  #5  
Old 01-18-2014, 06:58 AM
Member
 

Join Date: Feb 2007
Location: Morenci, AZ
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Door lock actuator problem is well covered in previous posts, as well. Don't know how to tag links, though!

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #6  
Old 01-18-2014, 07:02 AM
Member
 

Join Date: Feb 2007
Location: Morenci, AZ
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Something about removing a resistor or using foil to bypass it will make the actuators stronger. Something like that. Replacing actuators is supposedly very expensive due to having to buy the whole assembly.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #7  
Old 01-18-2014, 08:06 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2012
Location: Mt Vernon, IL
Posts: 117
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
When I bought my 2000 Ex, none of the locks worked and had the same symptoms as yours. YouTube has videos on how to fix yours, but I bought all 5 actuators off of eBay pretty cheap. They aren't terribly hard to swap out, and you can do all of them in a couple hours.

As far as the back up sensors go, if one doesn't work, none of them will. Have someone get in the driver's seat, turn the key forward but don't crank it over. Have them put their foot on the brake and put the vehicle in reverse (all while the vehicle is not running, mind you). Now, you go behind the vehicle and put your ear up to each sensor. There will be a clicking coming from the one or ones that do work. The one or ones that are not clicking are the failed component. Replace accordingly and that project is completed!

I've never had the lift gate failure to lock problem, so I can't help you with that one. Sorry! Good luck!
Reply With Quote Quick reply to this message
  #8  
Old 01-21-2014, 08:18 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Henderson, NV
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Rahn View Post
As far as the back up sensors go, if one doesn't work, none of them will. Have someone get in the driver's seat, turn the key forward but don't crank it over. Have them put their foot on the brake and put the vehicle in reverse (all while the vehicle is not running, mind you). Now, you go behind the vehicle and put your ear up to each sensor. There will be a clicking coming from the one or ones that do work. The one or ones that are not clicking are the failed component. Replace accordingly and that project is completed!
I tried this, all 4 sensors made a clicking noise. Would it be safe to assume all are good?
Reply With Quote Quick reply to this message
  #9  
Old 01-22-2014, 02:23 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2012
Location: Mt Vernon, IL
Posts: 117
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
You got me there....that is what I did on mine and what worked for me. Follow the link below for some additional information I found.

backup sensor connectors (repair how-to) - Ford Truck Enthusiasts Forums
Reply With Quote Quick reply to this message
  #10  
Old 02-01-2014, 09:37 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2007
Location: Henderson, NV
Posts: 147
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
got the door actuators replaced and all my door locks work again, need to do the liftgate next!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:31 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors