FUEL RAIL PUMP QUICK CONNECT ISSUE - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 01-03-2014, 04:36 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2013
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

Hey guys,

I have an '03 Excursion 7.3 Powerstroke and just replaced the fuel rail pump with an Airtex from Napa for like $150. The old female quick connect fitting on the inlet side of the rail pump disintegrated upon removal. The Airtex pump says on the box it has 2 male 5/16" quick connect fittings....and upon measuring with a micrometer they indeed measure 5/16" O.D. So I bought a replacement 5/16" quick connect female fitting that slides onto the male quick connect fitting, feels secure, but doesn't "click" into place....I feel it "seat" snugly but it can be pulled off with very little force....the female quick connect is definitely a 5/16" so why won't it click into place? Am I overlooking something obvious here? Thanks a lot
tripevans is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome