yay me new noises - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-08-2013, 12:24 PM
Premium Member
 

Join Date: Dec 2012
Posts: 175
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
yay me new noises

so today when i was driving the Ex coming to a stop on the last few feet i hear a crunching coming from the drivers side only. i replaced both front wheel bearings about a month ago, had the alignment checked and the tie rods and ball joints were in good shape. i replaced the brakes about 3 months ago with Oreillys best ceramic pads. i jacked up the front and i dont have any play on either side top to bottom or side to side. i do have a funky sound coming from the hubs when removed and you shake them. sounds like dropping bottle caps when i drive over bumps. any ideas what this might be before i start tearing crap apart again?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-09-2013, 02:50 PM
Compression Ignition Addict
 

Join Date: Jun 2012
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sway bar bushings? Or leaf spring bushings?
Reply With Quote Quick reply to this message
  #3  
Old 12-09-2013, 05:32 PM
Premium Member
 

Join Date: Dec 2012
Posts: 175
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
those are brand new as well. i installed a 6 inch lift with new springs and new shocks about 1000 miles ago. forgot to include that. but yes sway bar bushings would have been a good start.
Reply With Quote Quick reply to this message
  #4  
Old 12-10-2013, 08:19 AM
Powerstroke.org Fanatic
 

Join Date: Jul 2012
Location: Cedar City UT
Posts: 104
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
can you feel it in your feet?

sway bar isn't a crunching sound its more of a banging/somethings falling off.

my brothers 02 has a crunching/ creaking that you can feel in the feet. we can't seem to find it tho. maybe broken weld in the body?
Reply With Quote Quick reply to this message
  #5  
Old 12-10-2013, 08:39 AM
Compression Ignition Addict
 

Join Date: Jun 2012
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not to say this is it but are all your rivets tight on your frame? Can you get an idea of where its coming from? Leaf spring to axle bolts tight? How about the centering pin for the leaf spring? Track bar frame bracket? Just throwing out some stuff that's on that side. How about the shock tower, is it tight? (dont remember if its welded,bolted or riveted). On my Jeep last year I couldn't find a sound in Moab & it was driving nuts. Got home & decided to grease my Johnny Joints & found my frame was ripped/torn
Reply With Quote Quick reply to this message
  #6  
Old 12-10-2013, 06:58 PM
Premium Member
 

Join Date: Dec 2012
Posts: 175
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
its only when i hit the brakes for the last few feet before the truck comes to a complete stop. i pulled the brakes apart and its a cracked pad. about a 1/3rd of the pad was loose in between the caliper and the rotor. i pulled the chunk out and ordered EBC yellowstuff pads
Reply With Quote Quick reply to this message
  #7  
Old 01-05-2014, 06:23 PM
Premium Member
 

Join Date: Dec 2012
Posts: 175
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
so i took the truck out today and the damn sound it back but the pads are great. now at 70 it feels like a bad wheel bearing but they are new and when i lift the wheel up it has no play. when im backing up and hit the breaks hard its a awful crunching sound. i checked the torque on the leaf springs, shackles, u bolts, and track bar and everything was tight.
Reply With Quote Quick reply to this message
  #8  
Old 01-05-2014, 06:37 PM
Compression Ignition Addict
 

Join Date: Jun 2012
Posts: 232
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What brand wheel hub assembly did you get?
Reply With Quote Quick reply to this message
  #9  
Old 01-05-2014, 06:41 PM
Premium Member
 

Join Date: Dec 2012
Posts: 175
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
precision. they were the only one available local that had the studs included. couldnt get the stock studs out.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:16 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors