Ignition/dash module?? - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-04-2013, 07:02 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ignition/dash module??

Hi y'all:

I've got a 2000 Excursion with the 7.3 diesel.

I just had some work done to the truck, including new batteries and I think a fix for a fan running after the truck was shut off, draining the battery.

About 10 days after getting it back, I went to start the truck. I didn't wait long enough for the 'wait to start' light to go off, so it cranked a bit and I decided to stop turning it over. When I went to try it again, there was nothing. No cranking, nothing. Then it acts like the batteries are dead. No dash lights when I turn the key.

I have to admit I haven't tested the batteries, but they are new. Just wondering if there is some fuse or module that went, or what. My new batteries wouldn't be dead?? I don't even have a multimeter/tester.

NorthLink is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome