Tranny trouble flashing "OFF" light - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2008, 09:02 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Tranny trouble flashing "OFF" light

I have 110,000 miles on a 01 excursion 4x4 auto. I store this vehicle and only use it for pulling and vacationing (8,000 miles a year). This winter I noticed when it sat for awhile and was cold the torque converter would lock up so when put in reverse the vehicle would take off or die (no idle) It would do this when put in drive also, I wrote it off as being cold.
Now this spring it started shifting hard and not wanting to shift out of second gear. Friday, it started acting up again and this time the "OFF" light on the shift nob started to flash. I am assuming this is some kind of code. Does anybody know what this means.

I did install a tranny guage and have never had it get hot. Oil and filter was changed at the local diesel shop about 12,000 miles ago.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-26-2008, 12:04 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: waterboro, me
Posts: 2,190
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by 01 excuse View Post
I have 110,000 miles on a 01 excursion 4x4 auto. I store this vehicle and only use it for pulling and vacationing (8,000 miles a year). This winter I noticed when it sat for awhile and was cold the torque converter would lock up so when put in reverse the vehicle would take off or die (no idle) It would do this when put in drive also, I wrote it off as being cold.
Now this spring it started shifting hard and not wanting to shift out of second gear. Friday, it started acting up again and this time the "OFF" light on the shift nob started to flash. I am assuming this is some kind of code. Does anybody know what this means.

I did install a tranny guage and have never had it get hot. Oil and filter was changed at the local diesel shop about 12,000 miles ago.
Get it to a tranny shop to be diagnosed asap. You might be able to mod it and get some more life out of her. I chose to ignore mine since the problem went away. Bad choice, now my rebuilt tranny should be going in tomorrow, and pickup on wed.
Reply With Quote Quick reply to this message
  #3  
Old 06-08-2008, 01:22 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: waterboro, me
Posts: 2,190
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Did you get it to a shop? What happened?
Reply With Quote Quick reply to this message
  #4  
Old 06-09-2008, 06:47 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Took it to the ford dealer. Bad sprag gear and torque converter shot. Purchased a ford rebuilt tranny for $3141.00. I did get a 3 year 100,000 mile warranty but don't really know what the value of that is. The original went 115,000.
Reply With Quote Quick reply to this message
  #5  
Old 06-09-2008, 08:11 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: waterboro, me
Posts: 2,190
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Ouch, same thing I dealt with, Spent 3300 on a tranny built up. Said it would handle up to 600hp with a 3yr/70k warranty. Also gained 2-3 mpg over the course of a tank. Needless to say, I'm happy already.
Reply With Quote Quick reply to this message
  #6  
Old 06-09-2008, 08:32 AM
Conservative and Proud


 

Join Date: Nov 2005
Location: Oregon
Posts: 14,472
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by 01 excuse View Post
Took it to the ford dealer. Bad sprag gear and torque converter shot. Purchased a ford rebuilt tranny for $3141.00. I did get a 3 year 100,000 mile warranty but don't really know what the value of that is. The original went 115,000.
That's more than mine went! 98k on mine, but mine went because the pump went out.
Reply With Quote Quick reply to this message
  #7  
Old 06-09-2008, 08:59 AM
Cynic
 

Join Date: Jun 2007
Location: Fort Worth, Texas
Posts: 11,179
Thanks: 0
Thanked 4 Times in 3 Posts
Feedback Score: 0 reviews
I would have a BTS or John Woods valve body put it. Help prolong the life of the trans. Also, you really need to add another oil cooler or replace it with a larger one.
Reply With Quote Quick reply to this message
  #8  
Old 06-09-2008, 09:14 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Location: waterboro, me
Posts: 2,190
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Yeah, what they said. If I didn't already have everything upgraded, and the VB worked on, I'd do a JW or BTS VB. My ex shifts almost as hard as my old lightning with a shift kit, and I have no chip. Ands my stock tranny went 105k, mine went due to low line preasure. (Pump)

I had been hesitant to get a chip due to the tranny, now I have no excuse other than PMR's. LOL
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:48 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors