Gauge Lights Not Working - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 02-03-2013, 06:39 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Jan 2010
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Gauge Lights Not Working

I have a 2001 7.3 Ex. My gauge lights just quit working. The gauges all work fine (except the fuel gauge which has nothing to do with this). I have checked all the fuses and all are good. Any ideas?
Killin Time is offline  
post #2 of 2 Old 02-03-2013, 04:49 PM
Compression Ignition Addict
 
Join Date: Jan 2010
Posts: 450
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
This is super simple but, are they turned off at the switch? Was not mentioned and if not maybe the switch is going bad.

Chris
1984 F-350 XLT 4x4 4spd. 6.9 (project)
1996 F-250 XLT 4x4 5spd. 7.3
2001 Excursion XLT 4x4 Auto 7.3
AMSOILdealer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome