EX is cutting off.... - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-02-2007, 08:20 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2007
Location: MOORE CO. NC
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to whiteboystrokin
EX is cutting off....

K...last week got an engine light..it shut off...now the bastard is cutting off at low idle. Trying not go by the STEALERSHIP but it looks like it gonna have to happen. My buddies 99 F-350 7.3 is doing the same thing. Anyone else with the same elproblemo?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-02-2007, 08:21 AM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Read this link and see if its the same symptoms: 7.3 Cam sensor replacement procedure
Reply With Quote Quick reply to this message
  #3  
Old 11-02-2007, 08:24 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2007
Location: MOORE CO. NC
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to whiteboystrokin
Yeah Firefooll is the other the guy with the 99 f-350 he said he replace that same part a year ago and its still doing it. I can step out and leave my truck running and for some reason it seems when i reopen my door to get it in it cuts off. I know its nothing to do with it but thats happen twice and its shut off 3 times while idle at stopsign or light..one time actually going down the freaking road at 12 miles an hour.
Reply With Quote Quick reply to this message
  #4  
Old 11-02-2007, 08:27 AM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
My guess is the cps. Do you have a way to scan your truck for codes?
Reply With Quote Quick reply to this message
  #5  
Old 11-02-2007, 08:30 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2007
Location: MOORE CO. NC
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to whiteboystrokin
Yeah that my next step heading to the dealership on the way to the insurance company..two da ham crooks I even know. lol
Reply With Quote Quick reply to this message
  #6  
Old 11-02-2007, 08:32 AM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Here you go! Order two and keep a spare in your glovebox: Powerstrokeshop.com
Reply With Quote Quick reply to this message
  #7  
Old 11-02-2007, 08:37 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2007
Location: MOORE CO. NC
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to whiteboystrokin
Thanks! might have to buy 10 for me and my buddy
Reply With Quote Quick reply to this message
  #8  
Old 11-02-2007, 08:41 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Tye, TX
Posts: 218
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Send a message via ICQ to RedneckGirl Send a message via Yahoo to RedneckGirl
Sorry to hear about the trouble...luckily this is one thing I have yet to experience *knock on wood* however it seems more common than I would have thought. The owner of a truck accessories place had the same thing go on that you are describing. Ran his codes and sure enough it was the cam sensor. He replaced it himself and now it's running like it was before
Reply With Quote Quick reply to this message
  #9  
Old 11-02-2007, 08:43 AM
Powerstroke.org Fanatic
 

Join Date: Sep 2007
Location: MOORE CO. NC
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to whiteboystrokin
Well..sounds like everyone is saying the same thing..my luck...it will be something else. ahaahha Thanks yall!
Reply With Quote Quick reply to this message
  #10  
Old 11-02-2007, 08:43 AM
Desert Shield/Storm Vet

 

Join Date: Dec 2006
Location: Munising, MI.
Posts: 9,092
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Seems to be pretty common. The new grey cps with the new part number is supposed to be a better updated cps. Supposed to last 3 times longer I think I have read.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:17 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors