Electrical problems after it rains??? - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-26-2011, 05:48 PM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electrical problems after it rains???

Lately on my 2000 powerstoke Ex after it rains multiple dummy switches stay on, airbag, abs, service engine soon, overdrive light flashes and speedo stops working but only after it rains, it happened earlier this summer after a rain but after a couple of sunny days all was fine, now its happening again after this rainy weekend...help...help...help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-26-2011, 06:11 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,064
Thanks: 0
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
Driver side of windshield can leak onto PCM and/or fuse block.
Reply With Quote Quick reply to this message
  #3  
Old 09-26-2011, 10:49 PM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I also have the chime that let's me know I left the keys in the ignition or lights on going off even with the keys out but only with the drivers door is oven, time on the radio and pw & pl lights staying on after its closed and lock up too, you think water in the pcm and or fuse block can be the problem? Guess it makes sense, I'll have to check it out on my next day off. Any body else experience this???
Reply With Quote Quick reply to this message
  #4  
Old 09-27-2011, 04:08 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,064
Thanks: 0
Thanked 13 Times in 13 Posts
Feedback Score: 0 reviews
I think that's the door sensor. Mine does it too sometimes. Or did. Lights would stay on when all doors were shut.
Reply With Quote Quick reply to this message
  #5  
Old 10-11-2011, 12:49 AM
Member
 

Join Date: Jun 2007
Location: Richmond Tx
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
You guys ever find the culprit? I have some wierd radio and power window probs happening too. Just wondering if there is some famout Excursion short circuit problem I don't know about. All my problems have been on the driver's side.
Reply With Quote Quick reply to this message
  #6  
Old 10-11-2011, 04:23 PM
Powerstroke.org Rookie
 

Join Date: Jul 2010
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I tightened up the battery connections and it has seemed to have cleared up but it hasn't rained in a while either so not sure if the problem is going to come back, we'll have to wait and see???
Reply With Quote Quick reply to this message
  #7  
Old 10-11-2011, 04:39 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Posts: 5,466
Thanks: 2
Thanked 10 Times in 10 Posts
Feedback Score: 0 reviews
I remember something about the GEM module getting wet and causing all sorts of weirdness.....could be wrong though
Reply With Quote Quick reply to this message
  #8  
Old 10-15-2011, 06:27 AM
Member
 

Join Date: Jun 2007
Location: Richmond Tx
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
GEM module? Where is it? What is it? What's it look like?

I'm running into some wierdness as well, but not when it rains. My door switches are lighting up when the headlights are not turned on. Accessories don't work until I start the car and let it run about 13 seconds. Then I hear a "CLICK" from under the dash near the fuse block and wipers windosw etc work again. Just not the radio at all. What could make that click sound under the dash
Reply With Quote Quick reply to this message
  #9  
Old 10-17-2011, 03:34 AM
Compression Ignition Addict
 

Join Date: Jan 2011
Location: LaGrange, GA
Posts: 335
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by teacherman View Post
GEM module? Where is it? What is it? What's it look like?

I'm running into some wierdness as well, but not when it rains. My door switches are lighting up when the headlights are not turned on. Accessories don't work until I start the car and let it run about 13 seconds. Then I hear a "CLICK" from under the dash near the fuse block and wipers windosw etc work again. Just not the radio at all. What could make that click sound under the dash
I googled this and came up with an article describing how to get to it (its on the back of the fuse box panel). Just type Excurison GEM and it should be one of the first couple.

I just had something similar happen this week with the wiring coming from my radio though. I had pulled out my headunit to ground it and when shoving the box back in apparently I had kinded a wire or something because my speedo and odometer quit. Pulled out the unit and careful readjustment and its good now.
Reply With Quote Quick reply to this message
  #10  
Old 10-17-2011, 08:43 AM
Member
 

Join Date: Jun 2007
Location: Richmond Tx
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
looking4psd, To clarify, you said you pulled the headunit (Radio?) and there was a kinked wire that must have been the problem I did actually tie into the radio wires this summer to install a subwoofer. Do you think it could effect the power window switches? Had the door panel off, Saturday and couldn't fine a nick or anything in the wiring. Gives me something else to look at. Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:03 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors