Locking rear door/hatch - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-05-2011, 05:32 AM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Brunswick, GA
Posts: 373
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Locking rear door/hatch

I have noticed that the rear door/hatch does not lock when I use thekeypad on the drivers door or the inside lock all doors button.

Is this normal?

I see there is a keyhole there, but think it should be locked electricly also.

Could someone confirm this? Maybe there are some dirty contacts, I will look that over also.


Thanks,
Mike
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-05-2011, 06:31 AM
Premium Member
 

Join Date: Feb 2011
Location: Edmonton, Alberta Canada
Posts: 3,741
Thanks: 0
Thanked 20 Times in 19 Posts
Feedback Score: 1 reviews
On my Ex it locks and unlocks with the rest of the doors. I have never used a key to lock or unlock the doors or hatch, always the remote, keypad or the lock all doors button.
Reply With Quote Quick reply to this message
  #3  
Old 09-05-2011, 12:12 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Albuquerque
Posts: 328
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My rear hatch used to stick too. For the longest time it would not lock with the actuator. I had to take the rear plasics off and clean and lube all the working parts. Worked like a dream for a few months and now I have to click it 2-3 times to unlock it. Shouldn't be hard to remedy.......
Reply With Quote Quick reply to this message
  #4  
Old 09-05-2011, 07:42 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Brunswick, GA
Posts: 373
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Thanks for the replies. I know it is supposed to work now. I will try to remove some panels to see what is going on.



Mike
Reply With Quote Quick reply to this message
  #5  
Old 09-10-2011, 05:14 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Brunswick, GA
Posts: 373
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
WOW,

I have to tear apart and see what is going on and missing. I can't even lock it with the key. I thought I would try to see that it worked and it will not lock at all.

I guess I better pull out the service manual to get part numbers...


Mike
Reply With Quote Quick reply to this message
  #6  
Old 09-22-2011, 08:32 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Location: North MS
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I just noticed today that my 03' is doing the same exact thing. Glad i read this so i know that my truck isn't completely secured. Hope you update with your findings. When i get some time i will dig into mine and let you know if i figure it out. Thanks.
Reply With Quote Quick reply to this message
  #7  
Old 09-22-2011, 03:10 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Brunswick, GA
Posts: 373
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
I will when I get a chance. It may be a few weeks though.

Will yours even lock with the key? Mine will not.


Mike
Reply With Quote Quick reply to this message
  #8  
Old 09-23-2011, 05:14 AM
Powerstroke.org Rookie
 

Join Date: Aug 2011
Location: North MS
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No. At first I put the key in it wouldn't even turn i had to hold my mouth just right then it began to turn, but it did not lock the hatch i believe like previously commented something is loose on the inside.
Reply With Quote Quick reply to this message
  #9  
Old 09-23-2011, 06:19 AM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Brunswick, GA
Posts: 373
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
I just dug into mine... Seeing that yours was the same as mine, I had a few minutes to open mine up and discover what appears to be a small mess.

When yours would not turn, and finally did... Was most likely when the arm from the key tumbler to the lock mechanism broke off. My tumbler arm is broken and the rod is laying inside dangling around.

Wht did it do this... It appears that the locking mechanism in the handle release is completely froze up. I can see the power lock actuator attempting to move the lock, but it is frozen up. This is going to require removing the entire latch assembly to find the cause for being frozen up. It is definately a job for another day. There is 4 to 6 nuts that need to be removed from the inside, the power conncetion for the actuator and the 2 cables for the latch releases to be removed and it should come out.

Let me know if you tackle yours before I get a chance to.

Good luck !


Mike
Reply With Quote Quick reply to this message
  #10  
Old 10-15-2011, 06:33 AM
Compression Ignition Addict
 

Join Date: Mar 2011
Location: Brunswick, GA
Posts: 373
Thanks: 5
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Mine is now working

OK,

I went out this morning and took mine apart. Here is what I did to repair my lock...

Removed the lower inside hatch panel and the moisture barrier taped on. I took pictures of the left and right side needed to remove items and posted them circling what needed disconnecting. I did not include the actuator electrical connection in the pictures. It includes 3 11mm nuts, 2 cables and the handle rod.

Once I had the assembly out, I removed the actuator by pressing a lock release tab and it slid right off the mechanism. I then used air to blow any loose dust off. I then sprayed the mechanism down with PB Blaster and worked it through the motions many times. I then blew the PB Blaster off and then sprayed it all down with silicone spray and worked it through motions many times. I repeated the silicone again after blowing it off the first time. I figured this would work it into all possible locations better.

I then reassembled and the rear latch now locks with the electric locking system. I am not concerned about the tab broken off on the key tumbler for manual unlocking. Hopefully the actuator never breaks. If someone finds a part number for the tab on the tumbler, I will look into replacing it, but until then...........


Mike
Attached Thumbnails
Locking rear door/hatch-broken-tab.jpg   Locking rear door/hatch-left-side-remove.jpg   Locking rear door/hatch-right-side-remove.jpg   Locking rear door/hatch-assembly.jpg   Locking rear door/hatch-lock-mechanism.jpg  

Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:38 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors