factory trans temp guage - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 08-08-2011, 07:46 PM Thread Starter
Powerstroke.org Rookie
Join Date: May 2011
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
factory trans temp guage

my 02 has a tranny temp guage on the instrument panel. currently not reading. anyone know where the sending unit or temp probe attaches to transmission? any troubleshooting tips would be greatly appreciated. thanks
bobfish21 is offline  
Sponsored Links
post #2 of 2 Old 08-08-2011, 11:53 PM
Serving Our Country!
JSchuricht's Avatar
Join Date: Aug 2007
Location: Manor, TX
Posts: 2,961
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 23 Times in 22 Posts
Feedback Score: 2 reviews
Don't waste your time. It's basically an idiot light just like the volt gauge and temp gauge. By the time they register anything abnormal your already SOL.

JSchuricht is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome