Throttle issue bulletin or class action BS? - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-30-2010, 12:07 AM Thread Starter
Serving Our Country!
CutterN55's Avatar
Join Date: Feb 2010
Location: Jacksonville, NC
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Throttle issue bulletin or class action BS?

Wife showed me something that came in the mail last week about some BS about the throttle being screwy with the '01 7.3's Ex's. I guess the issue is you stomp skinny pedal and nothing happens...

Any body know what's up with this?

My truck is a slug when you mash the throttle from a stop...making pulling out into traffic a PITA. Once it's rolling and boost kicks, backs are pressed into the seats.

Tow pig
01 Excursion 7.3L with some goodies.
CutterN55 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome