Power Seat not working - Ford Powerstroke Diesel Forum
99-03 Ford Excursion Forum This forum is for topics relating to the Ford Excursion only.

User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 Old 01-02-2010, 03:34 PM Thread Starter
Member
 
Join Date: Sep 2007
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Power Seat not working

Okay, here is my problem,
I have a 2002 Excursion with all options, the interior is still in stock form with no wires randomly cut.
My driver side power seat, the power driver foot pedals and the driver seat memory buttons on the door do not work. I have checked all of the fuses, traced out wires and tried to jump switches. None of this helps. I can get the systems to operate if I run power straight from the battery to the motors though. What else should I check for in the wiring? I am at a loss and really miss my power seats, not to mention the wife can't drive my Excursion now. Any help would be greatly appriciated.

Last edited by eo1sc; 01-02-2010 at 06:35 PM.
eo1sc is offline  
post #2 of 20 Old 01-02-2010, 06:34 PM Thread Starter
Member
 
Join Date: Sep 2007
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
another question

Anybody have any suggestions before it goes to the dealer Monday?

Last edited by eo1sc; 01-09-2010 at 04:04 PM.
eo1sc is offline  
post #3 of 20 Old 01-12-2010, 01:07 PM Thread Starter
Member
 
Join Date: Sep 2007
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
So I finally got a factory Wiring diagram manual for all the Superdutys and Excursions for 2002, and traced my problem to the memory seat module. Gotta love these in depth manuals! I am surprised nobody had any ideas.
eo1sc is offline  
post #4 of 20 Old 01-13-2010, 07:35 PM
Member
 
Join Date: Jan 2010
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Great, just I just encountered the same problem so I'll be following your advice. I'm surprised too that no one else has replied?

Josh
Jboymx is offline  
post #5 of 20 Old 01-13-2010, 08:26 PM Thread Starter
Member
 
Join Date: Sep 2007
Posts: 48
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Josh,
If you have an 02 and need the wiring diagrams Ii can try to scan the diagram for you to check some other things first. Check you grounds too, one of mine was corroded.
eo1sc is offline  
post #6 of 20 Old 01-13-2010, 08:41 PM
Member
 
Join Date: Jan 2010
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I do i have an 2002 and would like those if you can get them to me.

Thanks!!!
Jboymx is offline  
post #7 of 20 Old 04-29-2010, 03:13 PM
Powerstroke.org Rookie
 
Join Date: Apr 2010
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
xcursion diagram

I am experiencing the same problem and would love a copy of the diagram.
ranchero64 is offline  
post #8 of 20 Old 07-27-2010, 06:29 PM
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hi, my X just started this Saturday. Was it the memory seat module or the corroded ground wire that caused your problem?
Morraar is offline  
post #9 of 20 Old 01-23-2011, 11:50 AM
Powerstroke.org Rookie
 
Join Date: Jan 2011
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
drivers power seat

I have an 03 Excursion and my drivers power seat has been on the fritz for a few months and now it does not work at all. The seat memory switch and the power pedals are also not working. Did you just replace the memory switch?
jzaccarine is offline  
post #10 of 20 Old 05-12-2011, 06:55 AM
Powerstroke.org Rookie
 
Join Date: Jul 2010
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Still acting up. If I unplug the wiring harness or pull the fuse, the seats will work fine until I start moving. Module?
Morraar is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome