Not starting: No crank, no dash lights, help - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-20-2014, 04:28 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not starting: No crank, no dash lights, help

Hi All,
New to the forum. I have a 2000 F250 7.3 manual tranny that was put away for winter storage and now will not start. Need it to get my weekend work done now that the snow is finally gone.

Symptoms:
- not cranking
- no dash lights (no oil light, battery light, etc.)
- radio works
- head lights work
- key buzzer works
- can hear clicking when turn key (assume solenoid OK)

Put in two new batteries, fully charger and terminals are clean.

Where should I start looking? Any help is greatly appreciated.
richardd is offline  
post #2 of 3 Old 05-20-2014, 08:24 PM
Compression Ignition Addict
 
blue99stroker's Avatar
 
Join Date: Oct 2011
Location: Chico, California
Posts: 4,812
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 111 Post(s)
Thanks: 18
Thanked 188 Times in 180 Posts
Feedback Score: 0 reviews
check fuse #30.
im guessing the wait to start light doesnt come on right?

my guess is the fuel heater shorted out and blew the fuse.
the fuse is for the pcm, and fuel heater.

99.5 f250 7.3 4x4 255k
PHP Phoenix, S&B, 4" Diamond Eye, Hpx, Stancor, RR Billet Wheel, RR AIH Delete, Autometer Gauges, Pro Comp leveled, Transgo Tugger, Billet TQ Converter, Warn Hubs, Int'l Up-Pipes, RR IC-Boots, Non-Ebpv Pedestal, High Flow Outlet, Hucorey's HPOP Lines, RR High Flow Fuel Fittings, RR OCR, Barder 360 Thrust Kit, 08 Tow Mirrors.

Dad-2000 7.3 108k miles, Autometer Gauges, Superchips 1705, RR AIH Delete, 6637, 4" Diamond Eye, BD Billet Wheel, TruCool Max
blue99stroker is online now  
post #3 of 3 Old 05-27-2014, 04:56 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: May 2014
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks blue99stroker, yes Wait to Start light does not come on.

Finally got around to it over the weekend.

Pulled out fuse #30 under the dash and visually checked. Looks good.

Any other thoughts?
richardd is offline  
Reply

Tags
no crank , no start cold

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome