7.3 runs a bit poor... Shop says tuner? - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-08-2014, 09:27 AM Thread Starter
Compression Ignition Addict
 
Join Date: Dec 2013
Posts: 407
Thanks: 41
Thanked 10 Times in 10 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
7.3 runs a bit poor... Shop says tuner?

Was hoping to get done feedback before getting a new tuner. I currently have a dp tuner f5 chip on my 2001 f250 with 160k miles with stock, 60hp tow, 80hp tow, 80hp Eco (city) and 120hp race. I had some turbo surge sometimes when the engine was cold as well as random jerking at 70mph with cruise.

Truck shows zero codes, injectors all are working properly and no compression issues. The mechanic told me it runs very poor in when it's cold except when it was set to stock mode. It also seems to slam into gear so I'm guessing my tranny is suffering a bit.

Any thoughts on whether a tuner chip not tuned well for my truck could be causing all my issues?

Any feedback would be great. This is also my first 7.3 and I bought it in December so I'm not quite sure how it should run.

Thanks in advance!
winona78 is offline  
post #2 of 4 Old 05-08-2014, 10:00 AM
Compression Ignition Addict
 
schlutzer's Avatar
 
Join Date: Apr 2012
Location: Stratford, Ontario
Posts: 2,437
Thanks: 34
Thanked 136 Times in 120 Posts
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
Feedback Score: 0 reviews
DP dumbs down injectors until it warms up. You'd be driving along and all of a sudden it gives you all your power, that could be your problem.

Turbo surge is turbo surge

When I ran DP it also slammed into gear

Please check out my 7.3 Enthusiast Facebook group! All are welcome! LINKY


Last edited by schlutzer; 05-08-2014 at 10:03 AM.
schlutzer is offline  
post #3 of 4 Old 05-08-2014, 10:20 AM Thread Starter
Compression Ignition Addict
 
Join Date: Dec 2013
Posts: 407
Thanks: 41
Thanked 10 Times in 10 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
Do you happen to know if that also applies to their new tunes? This chip has to be 3-4 years old.

Any recommendations for a different brand of tuner? I'd really like a highway Eco since 95% of my driving is highway.

Forgot to add in... I was originally going to get a wicked wheel to hopefully help the jerking and he made it clear he thought it was completely unnecessary.

Last edited by winona78; 05-08-2014 at 10:25 AM.
winona78 is offline  
post #4 of 4 Old 05-08-2014, 10:41 AM
Compression Ignition Addict
 
schlutzer's Avatar
 
Join Date: Apr 2012
Location: Stratford, Ontario
Posts: 2,437
Thanks: 34
Thanked 136 Times in 120 Posts
Mentioned: 0 Post(s)
Quoted: 17 Post(s)
Feedback Score: 0 reviews
They can change the tunes however you want. Even get rid of the retarded sensitive pedal if you want.

If you want to switch tuners you need to sell your chi.

Please check out my 7.3 Enthusiast Facebook group! All are welcome! LINKY

schlutzer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome