Stalling/Power Problem - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 03-21-2014, 07:40 PM Thread Starter
Member
 
Join Date: Oct 2007
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 18
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Stalling/Power Problem

This just started a while ago. I was heading up over a mountain pass abd kicked down to pass a semi. It pulled like a raped ape as usual, but when the rpm's hit about 2600 or so (75 mph area) all of a sudden it stopped pulling, tac stayed at 2600 but no power. I lifted the throttle and the tranny shifted back into overdrive, the rpm's dropped and once again I had throttle response. It was almost like I hit the rev limiter.

I tried it again, throttle down and pulled hard, rolling up speed but once again it just stopped pulling, only maintaining speed and tac stayed high until I lifted the throttle and it shifted again.

A mechanic buddy thought it was likely the IPR sensor, so today I replaced it. Took it for a drive and same thing, no change.

It doesnt do it as easy on flat pavement but more when more torque is needed, like up steep hills or under load.

Any ideas?

Last edited by huntnphool; 03-22-2014 at 08:36 PM.
huntnphool is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 03-22-2014, 08:54 AM
Compression Ignition Addict
 
blue99stroker's Avatar
 
Join Date: Oct 2011
Location: Chico, California
Posts: 4,572
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
Thanks: 18
Thanked 169 Times in 161 Posts
Feedback Score: 0 reviews
torque converter slipping? sound like it could be trans related.

99.5 f250 7.3 4x4 255k
PHP Phoenix, S&B, 4" Diamond Eye, Hpx, Stancor, RR Billet Wheel, RR AIH Delete, Autometer Gauges, Pro Comp leveled, Transgo Tugger, Billet TQ Converter, Warn Hubs, Int'l Up-Pipes, RR IC-Boots, Non-Ebpv Pedestal, High Flow Outlet, Hucorey's HPOP Lines, RR High Flow Fuel Fittings, RR OCR, Barder 360 Thrust Kit, 08 Tow Mirrors.

Dad-2000 7.3 108k miles, Autometer Gauges, Superchips 1705, RR AIH Delete, 6637, 4" Diamond Eye, BD Billet Wheel, TruCool Max
blue99stroker is offline  
post #3 of 3 Old 03-22-2014, 11:26 PM Thread Starter
Member
 
Join Date: Oct 2007
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 18
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by blue99stroker View Post
torque converter slipping? sound like it could be trans related.
Thought it was the tranny, had it rebuilt and issue is still there.
huntnphool is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome