Abs and airbag lights, no blinkers, no cruise control, no speedometer, no odometer, a - Ford Powerstroke Diesel Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 03-14-2014, 09:13 PM Thread Starter
Powerstroke.org Fanatic
 
01PowestrokeDSL's Avatar
 
Join Date: Mar 2007
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Abs and airbag lights, no blinkers, no cruise control, no speedometer, no odometer, a

I have been having these problems intermittently when the truck starts, but they usually go away after a few minutes. Initially I was thinking the batteries could be bad, or the alternator. Then was thinkin the speed sensor or PCM. I looked on the forum and there's a lot pointing to the clock spring, but my horn is working...

Any thoughts would be appreciated... I haven't seen a clear resolution posted on the site, mainly just a lot of questions. I will be taking the batteries and alternator out for testing tomorrow. Then I'll pull the speed sensor to see if there may be shavings on it. I will post what I find...

01 F250 XLT
F6 DP Chip
AFE Stage II
4" Magnaflow Exhaust
10.5" Lift on 38X15.50 MT Baja Claws
01PowestrokeDSL is offline  
post #2 of 11 Old 03-15-2014, 02:49 PM Thread Starter
Powerstroke.org Fanatic
 
01PowestrokeDSL's Avatar
 
Join Date: Mar 2007
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP!!! Its not the ABS sensor, or the battery/charging system... Hoping that it is just a Loose connection in the PCM, but my luck is not that good! I checked some fuses, which were all good, but the interesting thing is that there was power supplied to the PCM, but no power to the airbag or abs systems that I could tell from the fuses...

Come on guys, let me see some ideas!!!

01 F250 XLT
F6 DP Chip
AFE Stage II
4" Magnaflow Exhaust
10.5" Lift on 38X15.50 MT Baja Claws
01PowestrokeDSL is offline  
post #3 of 11 Old 03-15-2014, 04:00 PM
Compression Ignition Addict
 
sbluke55's Avatar
 
Join Date: Sep 2013
Location: Grand Junction, CO
Posts: 6,355
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 273 Post(s)
Thanks: 286
Thanked 492 Times in 464 Posts
Feedback Score: 1 reviews
Maybe your ignition is getting stuck in the start position instead of returning to run. After you start it make sure the key turns back a little.

Sent from AutoGuide.com Free App

01 f-250, Standard
Rev tech 4" lift,35" Mickey Thompsons MTZ
KC diy 66 stage 2, Full force 160/100 and custom tunes from PHP
Banks inner cooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
[/LEFT]
sbluke55 is offline  
post #4 of 11 Old 03-16-2014, 10:07 AM Thread Starter
Powerstroke.org Fanatic
 
01PowestrokeDSL's Avatar
 
Join Date: Mar 2007
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I will check that, I guess the switch could be going bad... Might not be making good contact.

01 F250 XLT
F6 DP Chip
AFE Stage II
4" Magnaflow Exhaust
10.5" Lift on 38X15.50 MT Baja Claws
01PowestrokeDSL is offline  
post #5 of 11 Old 03-16-2014, 10:14 AM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 14,263
Mentioned: 45 Post(s)
Tagged: 0 Thread(s)
Quoted: 508 Post(s)
Thanks: 462
Thanked 679 Times in 646 Posts
Feedback Score: 0 reviews
the ABS /cruise /speedo seem related but the turn signals and airbag are confusing
when thrown in there also

06 KR 4x4 BPD remote OEM Oil cooler /EGR cooler/water pump6 phase FICM , ARP studs,
Rize 4 link Toyo 37" camper modified special
For a truly terrible firearm experience I suggest Taurus
ZMANN is offline  
post #6 of 11 Old 03-17-2014, 07:00 AM Thread Starter
Powerstroke.org Fanatic
 
01PowestrokeDSL's Avatar
 
Join Date: Mar 2007
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah I have to find some time to dig through some schematics and see if I can find something that they all have in common. I checked voltages on some fuses and there are a few that should have power relating to the abs, airbag, and a few other things. Them not having power makes me think it could be a relay. Maybe one that should be clicking after startup or something...

Sent from AutoGuide.com Free App

01 F250 XLT
F6 DP Chip
AFE Stage II
4" Magnaflow Exhaust
10.5" Lift on 38X15.50 MT Baja Claws
01PowestrokeDSL is offline  
post #7 of 11 Old 03-17-2014, 04:46 PM Thread Starter
Powerstroke.org Fanatic
 
01PowestrokeDSL's Avatar
 
Join Date: Mar 2007
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Looks like a relay problem... I did a little tapping under the dash and everything started working.

Sent from AutoGuide.com Free App

01 F250 XLT
F6 DP Chip
AFE Stage II
4" Magnaflow Exhaust
10.5" Lift on 38X15.50 MT Baja Claws
01PowestrokeDSL is offline  
post #8 of 11 Old 10-29-2015, 06:49 PM Thread Starter
Powerstroke.org Fanatic
 
01PowestrokeDSL's Avatar
 
Join Date: Mar 2007
Posts: 114
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
This bug is back... Anyone have any suggestions? I also noticed there is no power to the AC circuit...

Anyone have any detailed schematics for this truck?
01PowestrokeDSL is offline  
post #9 of 11 Old 10-29-2015, 06:57 PM
Super Moderator

 
Heavy_GD's Avatar
 
Join Date: Aug 2013
Location: 804Va
Posts: 11,647
Mentioned: 60 Post(s)
Tagged: 1 Thread(s)
Quoted: 767 Post(s)
Thanks: 3,519
Thanked 789 Times in 738 Posts
Feedback Score: 3 reviews
Tap the dash again! !
Sorry Im no help.

GD - 06 CCSB FX4 Lariat
Quote:
Originally Posted by G8orFord View Post
My magic wand broke a few years back when my crystal ball fell on it. Ruined the ball too. So we're going to have to figure this one out another way. YOU NEED A MONITOR or at least a good scanner.
Heavy_GD is offline  
post #10 of 11 Old 10-29-2015, 07:23 PM
Premium Member

 
AU7POINT3's Avatar
 
Join Date: Jul 2013
Location: AUBURN, ALABAMA
Posts: 795
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 3
Thanked 46 Times in 43 Posts
Feedback Score: 0 reviews
The trucks are known to have some issues with the instrument cluster, maybe a bad ground. Water leaking around the windshield of SD trucks to the firewall causes a bunch of gremlins.

2002 F-250 LARIAT CCSB 7.3 AUTO 4X4 255,XXX
2004 EXPLORER XLT 4.0 AUTO 2WD 130,XXX
1966 MUSTANG COUPE 289 4 brl V8

IN-LAWS...
2004 EXPLORER SPORT TRAC 4.0 4X2 100,XXX
2004 F-250 RCLB 6.0 AUTO 4X2 376,XXX
2005 F-250 RCLB 6.0 AUTO 4x2 352,XXX

SOLD... 3 RANGERS, 3 F-150s, 3 F-250s, 96 COUGAR 4.6, 99 EXPEDITION 5.4, 65 66 AND 69 MUSTANGS

RE-ASSIGNED... MULTIPLE FORD POLICE INTERCEPTORS

AU7POINT3 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome