Solid left turn signal, right signal is fine - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-13-2014, 03:10 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: Pataskala, OH
Posts: 157
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Send a message via AIM to tristanlee85 Send a message via MSN to tristanlee85 Send a message via Yahoo to tristanlee85
Solid left turn signal, right signal is fine

Out of the blue, I noticed that when my lights are on (parking or headlights) and when I signal left, it just stays solid. Signaling right and everything is fine. If the lights are off, both signals work fine.

I have replaced the flasher relay under the dash, and got a whole new turn signal switch. The problem still occurs. The bulbs appear to be fine and I don't see any bad fuses.

I also noticed that the battery light is always on now too. These two issues probably happened around the same time. However, I have been driving a lot and don't appear to be dropping voltage across the batteries. Both batteries are Duralast Gold and less than 4 months old. The alternator is about 2 years old.

Any ideas what else to check?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-13-2014, 04:58 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: Pataskala, OH
Posts: 157
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Send a message via AIM to tristanlee85 Send a message via MSN to tristanlee85 Send a message via Yahoo to tristanlee85
Nevermind... after tearing everything apart and replacing the above that I mentioned, it turns out the trailer wiring was toast from backing into a snow pile. After unplugging that harness, everything worked fine again (except I do still have a battery light on).

If it wasn't for the burning electrical smell and smoke coming from the plug housing, I probably would have found it after the truck burned to the ground.
Reply With Quote Quick reply to this message
  #3  
Old 03-13-2014, 06:08 PM
Premium Member
 

Join Date: Apr 2012
Location: Stratford, Ontario
Posts: 2,257
Thanks: 33
Thanked 125 Times in 111 Posts
Feedback Score: 0 reviews
Lol I was just going to suggest the trailer wiring.

Mine screwed up and my right signal was staying on solid, but my left was flashing the third brake light too. I was so confused
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:15 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors