Speedometer Failure - Ford Powerstroke Diesel Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 Old 02-14-2014, 08:56 AM Thread Starter
Compression Ignition Addict
 
StrokinAlaska's Avatar
 
Join Date: Aug 2013
Location: Anchorage, Ak
Posts: 842
Thanks: 8
Thanked 34 Times in 33 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Speedometer Failure

I have a 99 f350, and lately my speedo will stop functioning until I get to a light and and come to a full stop. Then she kicks back in, or if I put her in park she will resume functions. Also, I noticed my Overdrive button will flash Off as this happens. My shifting is rough while this is happening so I'm pretty easy till I can get to the next light. Now this morning the Overdrive light just flashes no matter what. Any ideas ? I've heard a sensor above the rear axle is I remember right. Any help would be much appreciated!

05-07 Front
GlowShift Gauges
AFE C.A.I
4" d.p
TS-Performance 6 Position Chip
Wicked Wheel 2
Coolingmist Stage 1
14lbs Nitrous Oxide
(2) 52" VisionX Xmitter Led bars
VisionX Cannon 4.7"
VisionX Cannon 6.7"
(2) 42" RaceSport Led bar
(4) VisionX Solo Soltice
(4) RaceSport Duallys
Hids
Alpine INE-S920HD
20 Speaker Rockford Fosgate Stereo System
3 Bulk Packs of Ballistic
Smoked Cab Lights, Fender Lights, SwitchBack Leds
Tint
2.8" Front leveling kit
StrokinAlaska is offline  
post #2 of 13 Old 02-14-2014, 05:08 PM
Compression Ignition Addict
 
Join Date: Feb 2008
Location: Valley Springs
Posts: 330
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Yep, I would change that speed sensor on the rear axle.
99' Powerstroke is offline  
post #3 of 13 Old 02-14-2014, 05:12 PM
,,,,,,,,,,,,,,,,,,,,,,,,,
 
ZMANN's Avatar
 
Join Date: Feb 2008
Posts: 15,139
Thanks: 585
Thanked 740 Times in 707 Posts
Mentioned: 62 Post(s)
Quoted: 671 Post(s)
Feedback Score: 0 reviews
the differential mounted sender is called a "VSS" vehicle speed sensor
you can try to clean it before you buy a new one and check the connection ans wire for chafing

.
.
.
Please donate to DTR Ron's Memorial
https://www.gofundme.com/2464axqr
We Miss you Ronnie
RIP
ZMANN is online now  
post #4 of 13 Old 02-14-2014, 05:21 PM Thread Starter
Compression Ignition Addict
 
StrokinAlaska's Avatar
 
Join Date: Aug 2013
Location: Anchorage, Ak
Posts: 842
Thanks: 8
Thanked 34 Times in 33 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Gonna check it right now. Thanks I'll let you know what I find!

05-07 Front
GlowShift Gauges
AFE C.A.I
4" d.p
TS-Performance 6 Position Chip
Wicked Wheel 2
Coolingmist Stage 1
14lbs Nitrous Oxide
(2) 52" VisionX Xmitter Led bars
VisionX Cannon 4.7"
VisionX Cannon 6.7"
(2) 42" RaceSport Led bar
(4) VisionX Solo Soltice
(4) RaceSport Duallys
Hids
Alpine INE-S920HD
20 Speaker Rockford Fosgate Stereo System
3 Bulk Packs of Ballistic
Smoked Cab Lights, Fender Lights, SwitchBack Leds
Tint
2.8" Front leveling kit
StrokinAlaska is offline  
post #5 of 13 Old 02-15-2014, 06:53 PM Thread Starter
Compression Ignition Addict
 
StrokinAlaska's Avatar
 
Join Date: Aug 2013
Location: Anchorage, Ak
Posts: 842
Thanks: 8
Thanked 34 Times in 33 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
So I replaced the vss. Still having the same issue, not sure what else to do except a computer reset. Took a my Snap on versus to it and only code I pulled was trans temp sensor high . any suggestions.

05-07 Front
GlowShift Gauges
AFE C.A.I
4" d.p
TS-Performance 6 Position Chip
Wicked Wheel 2
Coolingmist Stage 1
14lbs Nitrous Oxide
(2) 52" VisionX Xmitter Led bars
VisionX Cannon 4.7"
VisionX Cannon 6.7"
(2) 42" RaceSport Led bar
(4) VisionX Solo Soltice
(4) RaceSport Duallys
Hids
Alpine INE-S920HD
20 Speaker Rockford Fosgate Stereo System
3 Bulk Packs of Ballistic
Smoked Cab Lights, Fender Lights, SwitchBack Leds
Tint
2.8" Front leveling kit
StrokinAlaska is offline  
post #6 of 13 Old 02-16-2014, 07:16 PM
Powerstroke.org Rookie
 
Join Date: Aug 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
some 4r100's have a speed sensor on the top side of the case to measure speed for pto option
yooper906 is offline  
post #7 of 13 Old 02-17-2014, 10:14 AM Thread Starter
Compression Ignition Addict
 
StrokinAlaska's Avatar
 
Join Date: Aug 2013
Location: Anchorage, Ak
Posts: 842
Thanks: 8
Thanked 34 Times in 33 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Is that different from the vss above the rear diff.?
I don't loose speedo anymore and i don't shift rough. smooth shifting and on time. But the OD just flashes now. Checked my battery grounds and the vss wiring all checks out good.

05-07 Front
GlowShift Gauges
AFE C.A.I
4" d.p
TS-Performance 6 Position Chip
Wicked Wheel 2
Coolingmist Stage 1
14lbs Nitrous Oxide
(2) 52" VisionX Xmitter Led bars
VisionX Cannon 4.7"
VisionX Cannon 6.7"
(2) 42" RaceSport Led bar
(4) VisionX Solo Soltice
(4) RaceSport Duallys
Hids
Alpine INE-S920HD
20 Speaker Rockford Fosgate Stereo System
3 Bulk Packs of Ballistic
Smoked Cab Lights, Fender Lights, SwitchBack Leds
Tint
2.8" Front leveling kit
StrokinAlaska is offline  
post #8 of 13 Old 02-17-2014, 08:15 PM
Powerstroke.org Rookie
 
Join Date: Aug 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
the sensor on the top side of the trans case at the back is the output shaft speed sensor(oss), the one on top front is the turbine speed sensor(tss). They both send input signals to the pcm for speed and shifting, they are also both the same part number if you dont have a pto case, the pto case uses a shorter tss. The trans temp sensor is built into the selenoid pack. If you have a trans temp guage that has a probe in the trans, compare that to the reading the pcm gets as shown on your scanner. Should be very close to the same. If the pcm is getting a false temp reading from the selenoid pack all the time that would b your code.
yooper906 is offline  
post #9 of 13 Old 02-17-2014, 09:28 PM Thread Starter
Compression Ignition Addict
 
StrokinAlaska's Avatar
 
Join Date: Aug 2013
Location: Anchorage, Ak
Posts: 842
Thanks: 8
Thanked 34 Times in 33 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I'll check it tomorrow at work.

I drove to Soldotna today at 10am, worked till 630pm and drove back got back at 9pm. 279 miles round trip. No issues with tranny yet. Of flashed the whole time. I didn't want to drive that distance on it but work is work :/

05-07 Front
GlowShift Gauges
AFE C.A.I
4" d.p
TS-Performance 6 Position Chip
Wicked Wheel 2
Coolingmist Stage 1
14lbs Nitrous Oxide
(2) 52" VisionX Xmitter Led bars
VisionX Cannon 4.7"
VisionX Cannon 6.7"
(2) 42" RaceSport Led bar
(4) VisionX Solo Soltice
(4) RaceSport Duallys
Hids
Alpine INE-S920HD
20 Speaker Rockford Fosgate Stereo System
3 Bulk Packs of Ballistic
Smoked Cab Lights, Fender Lights, SwitchBack Leds
Tint
2.8" Front leveling kit
StrokinAlaska is offline  
post #10 of 13 Old 02-17-2014, 09:33 PM
Powerstroke.org Rookie
 
Join Date: Aug 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
if you clear the code does it come back right away or do u have to drive a bit
yooper906 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome