front end squeek... - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 10-19-2008, 10:47 AM Thread Starter
Member
 
AMERICANTRUCKER's Avatar
 
Join Date: Feb 2008
Location: Miami, FL
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
front end squeek...

I can hear a squeeking noise in front end area after 20mph, sometimes don't hear anything but hearing it more often.....2002 pwrstrk 7.3 4x4. any one have an idea of what it can be? thanks.
AMERICANTRUCKER is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 10-22-2008, 02:37 PM
Premium Member
 
RadarRider's Avatar
 
Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,589
Thanks: 5
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by AMERICANTRUCKER View Post
I can hear a squeeking noise in front end area after 20mph, sometimes don't hear anything but hearing it more often.....2002 pwrstrk 7.3 4x4. any one have an idea of what it can be? thanks.
Have tried greasing your steering components? You should have them on your u/l balljoints(if newer), & i/o tie rods. Give 'em a good greasing and work the steering a little bit. Get the truck up on jack stands & check for play in your tie rods. Also, throw a prybar under the tire, & wiggle the tire vertically back & forth to check for play in your ball joints. Check the u-joints on your front axles for play as well.

"HEAVY" 2001 F-250 XLT 4x4 EC SB:
TW 6pos chip, S&B CAI, Monster 4" exhaust w/ Power Elbow, Big Head WGA, Technicooler, ITP boost fooler, Gen 1 Wicked Wheel, Six-Gun Tuner, Optima Yellow Tops, AutoMeter(Boost, Trans, EGT), CCV mod, MTS TC, MTS valve body, Trans Tech performance rebuild kit, TransGo shift kit, Hornblasters 242 Shocker Train Horns.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RadarRider is offline  
post #3 of 6 Old 10-22-2008, 02:47 PM
Compression Ignition Addict
 
fordpwrstroke7's Avatar
 
Join Date: Nov 2005
Location: Far From Bieber
Posts: 2,069
Thanks: 0
Thanked 2 Times in 2 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Do you have a lift? Could be bushings on your sway bar end links. Need more info.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008 F-350 CCLB
2004 F-250 CCSB (sold)
1997 F-250 CCSB (sold)
1994 F-250 ECLB (sold)
fordpwrstroke7 is offline  
post #4 of 6 Old 10-22-2008, 03:06 PM
Compression Ignition Addict
 
03f250stroke's Avatar
 
Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
check your sway bar bushings, they go on the our front ends, i had to replace mine on my 04 with only like 30k miles on it. really tighten the front end up too

-Evan

6.HO
tuned by Eric
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

12.3

Quote:
Originally Posted by shu873 View Post
Yeah, but your trucks a freak of nature...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
03f250stroke is offline  
post #5 of 6 Old 10-30-2008, 04:16 PM Thread Starter
Member
 
AMERICANTRUCKER's Avatar
 
Join Date: Feb 2008
Location: Miami, FL
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Already replaced sway bar bushings....This is wierd, it seems to squeek more and louder when its cold, it sounds like it comes from the passenger side, around the wheel area, its not as loud when it warms up, it starts after 20mph, braking or turning does not affect it, I don't see leaking fluid anywhere, and wheel speed seems to effect it very little....no lift kit installed, factory front end...its just a squeek,squeek,squeek.........annoying! Thanks for any input.
AMERICANTRUCKER is offline  
post #6 of 6 Old 10-30-2008, 04:26 PM Thread Starter
Member
 
AMERICANTRUCKER's Avatar
 
Join Date: Feb 2008
Location: Miami, FL
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Think it might be shocks??
AMERICANTRUCKER is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome