Reman injector won't fire - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-20-2014, 07:02 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2014
Posts: 96
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Reman injector won't fire

I have a reman injector that will not fire. I have tested absolutely everything short of tearing the injector apart. No oil comes out, no fuel comes out. Electrically the truck is perfect. I swapped idms with a known good one an nothing. This is the 6th one i've replaced and of course it's my fault or the trucks fault. Now before i replaced all 8 of these the only problem the truck had was cold starting. Since nov 1 i have replaced 6 of these. The last one i replaced was one that had a compressionwqsher go bad and blew out, the inj worked but was nasty. So i replaced that inj with a clean one from the remanufacturer and now it's not working. What would make it not work? Is there anything I can do to make it work?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-20-2014, 09:42 PM
Compression Ignition Addict
 

Join Date: Oct 2011
Location: Chico, California
Posts: 3,583
Thanks: 17
Thanked 108 Times in 103 Posts
Feedback Score: 0 reviews
well first off is your uvch bad
Reply With Quote Quick reply to this message
  #3  
Old 01-20-2014, 09:55 PM
Compression Ignition Addict
 

Join Date: Jun 2010
Posts: 204
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
what he said^^^^^
Reply With Quote Quick reply to this message
  #4  
Old 01-20-2014, 10:44 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2014
Posts: 96
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
No sir every thing that is or could be electrical is absolutely perfect. All electronics have been cleared it does not fire. If i idle it i unplug it no change plug it in no change. Pull it out and the tip is still very clean. No oil flow at all through deflector. Did not pass buzz test did pass contribution test. I can operate it on the system you here it click but very very faint. The others sound like bees this one sounds like spanish fly. Anything electronic is working 100% or better i even did the idm mod and everything that works is working very nicely. The injector i pulled out that was muffed up worked but needed cleaned so we swapped em and within 3 hrs of pulling the new one was in and nothing. The light i didn't have i now have. All oil and fuel pressures are perfect new icp and ipr, hpop was cleaned of all debris as was the fuel system in both heads.

So internally what could cause and injector to fail? It's reman never been used. Could the magnet be junk? Could the poppit valve be stuck? Could the plunger be stuck? But if i'm not moving oil i'm not moving fuel. Sooooo?
Reply With Quote Quick reply to this message
  #5  
Old 01-20-2014, 10:56 PM
Rodslinger's B1TCH
 

Join Date: Mar 2012
Location: Abbotsford BC
Posts: 1,312
Thanks: 11
Thanked 56 Times in 54 Posts
Feedback Score: 0 reviews
If you take the 4 solenoid screws out of the top of that injector there is an armature plate that is about 1/4" thick that is held down with an odd screw. That plate needs to be tight or the injector won't work.

I had a loose one on one of my injectors that I tightened down with purple locktite and needle nose pliers.

It's worth a look. Also test that solenoid for resistance while it's out. I think 1.8 ohms is about right. You should also test that solenoid back through to the main idm harness. If you've replaced the uvch, that might be wired wrong from the factory too.
Reply With Quote Quick reply to this message
  #6  
Old 01-21-2014, 05:43 AM
Powerstroke.org Fanatic
 

Join Date: Jan 2014
Posts: 96
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Plate was tight, my thought is magnet.
Reply With Quote Quick reply to this message
  #7  
Old 01-21-2014, 04:58 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2014
Posts: 96
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Is it possible to hurt the magnet on install? Like hitting to hard?
Reply With Quote Quick reply to this message
  #8  
Old 01-21-2014, 08:39 PM
Rodslinger's B1TCH
 

Join Date: Mar 2012
Location: Abbotsford BC
Posts: 1,312
Thanks: 11
Thanked 56 Times in 54 Posts
Feedback Score: 0 reviews
i think if you damaged it, it would be visible. did you do a resistance check on that solenoid?
Reply With Quote Quick reply to this message
  #9  
Old 01-21-2014, 08:58 PM
Powerstroke.org Fanatic
 

Join Date: Jan 2014
Posts: 96
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Well its a weird little setup inside em and a hard enough hit might dislodge something muy importante. Yea i tested it but i dont remember what the ohms were i think it was in spec if i remember. But its been a few days.

Last edited by Dzlnzl; 01-21-2014 at 09:00 PM. Reason: Potato
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:09 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors