Motor Just...DIED - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-19-2014, 10:33 PM
Premium Member
 

Join Date: Jan 2014
Location: St.Peters, Mo
Posts: 27
Thanks: 9
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Motor Just...DIED

Hey everyone, I have an issue, well my truck has the issue! I recently had my motor rebuilt, bored .30+, new heads, 230cc hybrid injectors, T-500 HPOP, a 6.0 inner cooler, and BD Triple Disc Converter. Had to get a tune from Jody at DP till I get live tuned in the near future. My issue is this, despite the slight turbo lag, three times now as I approached a stoplight, let off throttle and the truck "just died"! No blurbs, hiccups, shimmies or shakes, just quit, and I was still rolling. I put in neutral and she started right back up! Thankfully! Did not die again, until after I shut down for 1st time 45min or so, and then again this morning after sitting all night. I suspected CPS so I swapped that out, went for a ride and seemed like I had no power. I pulled over, loaded tune to stock, then reloaded my hybrid tune. Took off fine, 2miles later, died again, and re-fired with no issue since. I'm stumped. Any thoughts or suggestions?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-20-2014, 12:14 AM
Compression Ignition Addict
 

Join Date: Nov 2012
Location: Augusta, GA
Posts: 184
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Check the nut on the ipr? I believe the t500 uses the same ipr setup. I may be wrong. But mine was doing that and it was because the ipr nut wasnt on and allowed it to move around.
Reply With Quote Quick reply to this message
The Following User Says Thank You to kbragg430 For This Useful Post:
jeffHstL7.3 (01-20-2014)
  #3  
Old 01-20-2014, 03:26 AM
Premium Member
 

Join Date: Jan 2014
Location: St.Peters, Mo
Posts: 27
Thanks: 9
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks KB, I will check that first thing
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:04 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors