hydroboost question - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-05-2008, 05:36 PM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2007
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
hydroboost question

The other day I was taking my truck off road and was flooring it through some dirt. The steering and brakes when dead shortly after that. I replaced the pump with an OEM one and my steering works great now. However when I step on the brake pedel it kinda pulsates (I dont have ABS)..sometimes the pedal drops and then the booster kicks in and pushes the pedal back up. Or when you come to a stop for a split second there isnt power assist then it kicks in a second later. Is there any parts to service on the hydroboost? Thanks
makaveli200369 is offline  
post #2 of 3 Old 10-06-2008, 05:59 AM
Powerstroke Junkie


 
NCHornet's Avatar
 
Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,308
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 51 Times in 11 Posts
Feedback Score: 0 reviews
I would start by a good bleeding of the system.

NCH

NCH
Proud Father of USAF Airman


2000 F350 DRW,CC,LB, 4X4, Western Hauler Pkg.
Ford AIS/ BTM, FTVB
My CCV MOD, Coolant filter
06 Grill, 05 lights,6.0 trans cooler
Cyro/Hawks, JVC Touchscreen HU, JL C5's, Infinity 800watt amp,
DP tunes, 60 tow/80 e/120 race, on a SCT2 tuner
P3 controller, Brite Box Turbo Lifesaver
KMC Wheels x 4

http://s132.photobucket.com/user/NCH...=recent&page=1

Friends Don't Let Friends Drive Trucks With Generic Tunes
NCHornet is offline  
post #3 of 3 Old 10-06-2008, 10:14 AM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2007
Posts: 397
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
I believe the hydroboost and the actual brakes hydraulic system are separate. I don't see why the pump going out would cause air in my brake system? Am I wrong? My brakes and pedal were working perfectly prior to the pump going out.
makaveli200369 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome