2000 kepps blowing wiper fuse - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-28-2013, 10:31 AM Thread Starter
Member
 
Join Date: Oct 2010
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2000 kepps blowing wiper fuse

My 2000 F 250 has started blowing wiper fuses. Every time it rains and I put the wipers on the fuse blows. It happens when the wipers are on the timer. I haven't noticed any water around the fuse panel,but I know there was a problem with the windshields not sealing well and water dripping on the GEM and fuse box. Any ideas. It started to happen about a month ago when my truck was in for service. I have had a lot of work done over the last few months. Oil pan,timing cover ,CPS,Rear pinion bearing,brakes,etc. When it happened at my mechanics they went to replace the fuse and as the mechanic was putting in a new one his hand touched one of the relays and the truck shut down. Not sure if the two things are related or not. Truck wasn't showing any codes.
JLimb is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome