Battery or altenator prolems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-07-2013, 07:59 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Battery or altenator prolems

I was driving to work this evening in my 02 F250, and started having issues I've never seen before. My ABS light came on, then the radio started cutting out, then another dash light came on. Then I noticed all my lights getting weak, and all of this happened within a distance of five miles. The truck never died, and I've been driving it around all day. The batteries aren't that old, and the alternator was rebuilt a little over a year ago. The battery light never came on either, so I'm lost.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-07-2013, 09:19 PM
Powerstroke.org Sponsor

 

Join Date: Apr 2010
Location: Defiance
Posts: 4,236
Thanks: 323
Thanked 87 Times in 83 Posts
Feedback Score: 1 reviews
Voltage regulator is prolly wiggin out. Very common for alts to go bad nowadays.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #3  
Old 12-07-2013, 09:24 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What's the best way to find out if that's it or not?
Reply With Quote Quick reply to this message
  #4  
Old 12-07-2013, 09:27 PM
Powerstroke.org Sponsor

 

Join Date: Apr 2010
Location: Defiance
Posts: 4,236
Thanks: 323
Thanked 87 Times in 83 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by kc8ufo View Post
What's the best way to find out if that's it or not?
Since its intermittent maybe your local parts store can check it and it will give them the symptoms.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #5  
Old 12-07-2013, 09:45 PM
Powerstroke.org Rookie
 

Join Date: Dec 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have to get it there first. After I parked it I tried to start it and the batteries are dead.
Reply With Quote Quick reply to this message
  #6  
Old 12-08-2013, 01:21 AM
Premium Member
 

Join Date: Apr 2012
Location: Stratford, Ontario
Posts: 2,121
Thanks: 31
Thanked 118 Times in 104 Posts
Feedback Score: 0 reviews
If your alternator did crap out our trucks will run for up to 2 hours on a good charge during the daytime, I had to make a trip like that.

Hucorey is right, alternators are notorious for not living long lives anymore, the 7.3 seems to kill them particularily fast. Every 7.3 I've been around now has a replaced alternator


You said it's been rebuilt, was that you went to A parts store and got a rebuilt unit or did you take it to a good shop and have it rebuilt with known Quality parts? If it's parts store, there is a decent chance of was rebuilt with China crap and well, that's no good.

Just a formality suggestion since it sounds like it's not charging at all but test the volts while running and see what you get. If by chance that's good, I would look next at the ground wires on your batteries and hope it's just that simple
Reply With Quote Quick reply to this message
  #7  
Old 12-09-2013, 07:38 AM
Powerstroke.org Sponsor

 

Join Date: Apr 2010
Location: Defiance
Posts: 4,236
Thanks: 323
Thanked 87 Times in 83 Posts
Feedback Score: 1 reviews
Very common for the 6.0l too. Our HEUI systems are picky. The 6.0l are more so with their FICMs. You'll never go wrong with a DC Power alt. Worth every penny.

Schultzer is correct on the two hr part. It just happened to me this summer. Right at two hours left to drive coming home from vacation I pretty much coasted into the driveway.

Sent from AutoGuide.com Free App
Reply With Quote Quick reply to this message
  #8  
Old 12-25-2013, 03:23 PM
Powerstroke.org Rookie
 

Join Date: Dec 2011
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
FYI....

New batt doesn't mean it can not be defective. Just had one of my Sears Plat go bad after about 9 months. The high output alt and the other bat is working great.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:29 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors