Intermittent "Service Engine Soon" Light - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-17-2008, 09:17 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Intermittent "Service Engine Soon" Light

I have a stock 2000 F-350 with a 7.3 and 133,000 or so miles. I have owned it for 4 months and love the truck.

2 Days ago my "Service Engine Soon" light came on for a few minutes (maybe 5) and went out.

Yesterday when I started it in the morning it came on and stayed on and it began running rough and under-powerd.

On some advice I changed the fuel filter (it had only 3000 miles on it) and afterwards the light went out and it ran fine for a drive of about 50 miles.

When I started this morning it came on again. The light also went on an off a few times including a 15 minute stretch where it stayed off and it ran fine.

Right now it has stayed on for about 10 miles and is running poorly.

Any suggestions?

Thanks

Arthur
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-17-2008, 09:34 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 30,948
Thanks: 106
Thanked 88 Times in 82 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Get it on a scanner and see what the codes are that will help with diagnosis
Reply With Quote Quick reply to this message
  #3  
Old 08-18-2008, 09:55 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No Error Codes - Light Still on

There are no error codes showing up on a MAC scanner.

I cleaned the EBPV sensor and removed and cleaned the tube (it was clogged).

It is now running very rough and appears not to be firing on all cylanders.

I am just about to take it to the dealer.

Any suggestions?

Thanks

Arthur
Reply With Quote Quick reply to this message
  #4  
Old 08-18-2008, 09:57 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 30,948
Thanks: 106
Thanked 88 Times in 82 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Quote:
Originally Posted by ArthurBNH View Post
There are no error codes showing up on a MAC scanner.

I cleaned the EBPV sensor and removed and cleaned the tube (it was clogged).

It is now running very rough and appears not to be firing on all cylanders.

I am just about to take it to the dealer.

Any suggestions?

Thanks

Arthur
If the SES light is on there are codes stored. Do you have the diesel software with the MAC scanner. If not there are codes it wont pick up
Reply With Quote Quick reply to this message
  #5  
Old 08-19-2008, 07:03 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
News from the dealer

The dealer got back to me this mrning and told me it was the injector harness on one side. They want $1380

Ouch!

I am sure I can by the parts cheaper than they are charging me and get a god mechanic to do it.

Any thoughts?

How much should a harness cost and where should I get one?

Thanks
Reply With Quote Quick reply to this message
  #6  
Old 08-19-2008, 07:05 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 30,948
Thanks: 106
Thanked 88 Times in 82 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
If hes talking about the UVC harness, DIY it thats cheap and fairly easy. If you need help theres plenty of people here that have done it
Reply With Quote Quick reply to this message
  #7  
Old 08-19-2008, 07:14 AM
Powerstroke.org Rookie
 

Join Date: May 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Harness Replacement

All he told me it was the injector harness.

I am going to call IH local.

I have heard that I should to the glow plug harness at the same time as it is apart.

Is that true?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:43 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors