turn signal issue - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-21-2013, 08:32 PM Thread Starter
Powerstroke.org Rookie
Join Date: Nov 2012
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
turn signal issue

Just replaced my fuse panel and gem and am having an issue. When I hit the left turn signal it will light the signal, but it doesn't blink. Right signal functions as it should.

This problem occurs when my lights are on. If the lights are off and I hit the left signal, my left signal works. Problem is, my dash lights blink with it. Also, if I hit my brakes while my lights are off, the dash lights come on.

Grounding issue? I really am pretty clueless when it comes to tracing down auto electrical hassles so I really appreciate all your help.
rohleder644 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome