2003 F-250 7.3l Speed Sensor / ABS Problems - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-19-2013, 10:19 AM Thread Starter
Powerstroke.org Fanatic
Strokin In Texas's Avatar
Join Date: Aug 2011
Posts: 92
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Exclamation 2003 F-250 7.3l Speed Sensor / ABS Problems

I have a 2003 f-250 7.3l 4x4.
I replaced both front hub assembly's. After doing so my ABS light came on. I scanned it and said "front left speed sensor failure".

After examining the speed sensor I saw it had rubbed on the tire and wore a hole in it. I replaced with original (working) speed sensor. The ABS light is on at times but brakes fine, other times ABS light is off but at 20mph or less when braking truck pulls hard to the right. I assume it's applying more braking power to the passenger side than drivers side.

I assumed that sensor must also be bad, so I replaced with other original (previously working) sensor. Does the exact same thing.

When changing for the second time I noticed there was some clean new grease in some spots on the tone ring. Could that cause my problem? Note it was not an extreme excessive amount. If that's not the problem where else should I be looking?



Strokin In Texas is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome