High EGT's and Turbo noise - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-05-2008, 12:46 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
High EGT's and Turbo noise

OK soon after installing my DP-tuner i began to hear whinning from my turbo. i had surging before so i thought my turbo was going out. I checked for play in the wheel and it checked fine. Im thinking that i have a turbo leak, but from what ive read on here most people noticed drop in boost pressure and power. I can boost to about 28psi. I can not even tow my boat to the lake with my truck because of my egt's. Using stock setting and going up a fairly steep grade i can only go about 40mph at 1100 egt. At 60mph not towing on level i am ussually at about 800 to 850 degrees. So i guess what im asking is if a turbo leak can cause a loud whine, high boost, and no reall loss in boost or power? Also i checked all hose connections, cleaned them and retightened. so possible hole in intercooler? Thanks for any help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-05-2008, 09:37 PM
Banned
 

Join Date: Feb 2008
Location: Northampton,MA
Posts: 792
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to blizzardwarrior7
Possibly an intercooler related problem....That can result in white smoke as well.
Reply With Quote Quick reply to this message
  #3  
Old 08-05-2008, 09:46 PM
Banned

 

Join Date: Jan 2008
Location: Belle Chasse
Posts: 3,445
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I am 99.99999% sure I know exactly what your problem is.

Cracked bellows in your up-pipe.

open your hood,...have someone rev your engine(try to smoke)...and if you see black smoke coming up...that's your problem.....I'd almost bet on it ...with the symptoms you gave.....

wanna know, how I know.....exact same symptoms on mine.




let me know if I was right...or wrong...when you get around to investigating the problem.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:12 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors