starting problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-29-2008, 01:33 PM
Powerstroke.org Rookie
 

Join Date: Jul 2008
Location: Rockwall, Texas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
starting problem

My 2000 F-350 7.3 was getting slow to start and I noticed corrison on my battery terminals, so I cleaned all posts and cables on both batteries. Then a couple of days later the truck won't start at all, it wouldn't crank, just clicked...So I replaced both batteries, which were well over 3 years old. But this didn't help. The truck still won't crank, it just clicks. What could or would be my next step.

Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-03-2008, 01:50 PM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ptall View Post
My 2000 F-350 7.3 was getting slow to start and I noticed corrison on my battery terminals, so I cleaned all posts and cables on both batteries. Then a couple of days later the truck won't start at all, it wouldn't crank, just clicked...So I replaced both batteries, which were well over 3 years old. But this didn't help. The truck still won't crank, it just clicks. What could or would be my next step.

Thanks
Your next 2 areas to check would be your starter & alternator. Your alternator has an internal voltage regulator that's prone to failure over some time. See if there's a local parts store or armature shop that can bench test your alt. If it's not your alt., check the connections on your starter. If the connections are ok, you can pull your starter & bench test it yourself or bring it to the parts store/armature shop.
Reply With Quote Quick reply to this message
  #3  
Old 08-03-2008, 03:01 PM
Premium Member
 

Join Date: Jun 2008
Location: Around
Posts: 1,042
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thumbs up fix psd

i would also check the starter switch,
Reply With Quote Quick reply to this message
  #4  
Old 08-06-2008, 01:56 PM
Powerstroke.org Rookie
 

Join Date: Jul 2008
Location: Rockwall, Texas
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks, got it fixed...It was the starter. Thanks again for the suggestions...
Reply With Quote Quick reply to this message
  #5  
Old 08-16-2008, 10:32 PM
Compression Ignition Addict
 

Join Date: May 2007
Location: Laramie, WY
Posts: 2,115
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mines gettin kinda slow... all connections are good.
after it starts, i noticed it going WHEEEEEEEEE as the starter spools down and the engine is running.

is this normal?

96 f350 209k mi

Last edited by POWERSMOKIN; 08-16-2008 at 10:45 PM.
Reply With Quote Quick reply to this message
  #6  
Old 08-17-2008, 03:38 AM
Other vehicle is an F250
 

Join Date: Jul 2007
Location: N. Pickens County S.C.
Posts: 18,324
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by POWERSMOKIN View Post
mines gettin kinda slow... all connections are good.
after it starts, i noticed it going WHEEEEEEEEE as the starter spools down and the engine is running.

is this normal?

96 f350 209k mi
Sounds like the starter is just happy to have helped out again!

Sorry, couldn't help myself! Hope you find your answer soon. At least I bumped you back to the top.
Reply With Quote Quick reply to this message
  #7  
Old 08-17-2008, 06:07 AM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Hank View Post
Sounds like the starter is just happy to have helped out again!

Sorry, couldn't help myself! Hope you find your answer soon. At least I bumped you back to the top.
That was good!
Reply With Quote Quick reply to this message
  #8  
Old 08-17-2008, 08:53 AM
Compression Ignition Addict
 

Join Date: May 2007
Location: Laramie, WY
Posts: 2,115
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Hank View Post
Sounds like the starter is just happy to have helped out again!

Sorry, couldn't help myself! Hope you find your answer soon. At least I bumped you back to the top.
well thank you for that.
Reply With Quote Quick reply to this message
  #9  
Old 08-17-2008, 09:51 AM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by POWERSMOKIN View Post
mines gettin kinda slow... all connections are good.
after it starts, i noticed it going WHEEEEEEEEE as the starter spools down and the engine is running.

is this normal?

96 f350 209k mi
Describe the 'WHEEEEEEEEEE' sound. There might be a possibility your input gear is still spinning after it's been disengaged. You can bench test your starter to see if this is the problem.
Reply With Quote Quick reply to this message
  #10  
Old 08-17-2008, 11:21 AM
Compression Ignition Addict
 

Join Date: May 2007
Location: Laramie, WY
Posts: 2,115
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
its just like, a whirring, not like an overused pencil sharpener with a shot bearing, just like the clutch opened up, and it goes from like 1,500 rpm to 0 winding down, but ive never heard any other starter do that.

How would i bench test it? and where is it at?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:19 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors