Couple Of Issues (need inspection) - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-28-2008, 11:18 AM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: Mass
Posts: 237
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Couple Of Issues (need inspection)

#1 Brake Light is still on in dash, messed around with the connection near the E-brake took it on and off but no luck. any suggestions?
#2 Drivers side break light doesnt work? Blinker works but blinks faster than normally, and regular driving lights work, but as soon as i apply the brake its doesnt light. I changed the build twice, any other suggestions?
#3 Windsheild wipers; All of the sudden my windshield wipers on work on the continuous setting and the fast setting. If i put it on one of the settings that have a delay the wippers move but will stop in the middle of my windshield then move a little again, and stop? any one have this issue before?

Thanks All
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-03-2008, 05:32 PM
The Screwy HEUI
 

Join Date: Jan 2008
Location: Smithfield, RI
Posts: 4,585
Thanks: 5
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by joelucci33 View Post
#1 Brake Light is still on in dash, messed around with the connection near the E-brake took it on and off but no luck. any suggestions?
#2 Drivers side break light doesnt work? Blinker works but blinks faster than normally, and regular driving lights work, but as soon as i apply the brake its doesnt light. I changed the build twice, any other suggestions?
#3 Windsheild wipers; All of the sudden my windshield wipers on work on the continuous setting and the fast setting. If i put it on one of the settings that have a delay the wippers move but will stop in the middle of my windshield then move a little again, and stop? any one have this issue before?

Thanks All
Can't really help you much with #1, but my best suggestion for that would be to check your parking brake cable & shoes. There's a possibility that something in your parking brake cable ***'y is on the fritz. Also check your brake fluid level. I think, but not sure, your parking brake light will come on if it's low. As for #2, check your flasher relay(for irregular blinking problem). For #3, sounds like you need to check your wiper switch. If it's not that, it might be wiper motor itself. Wait until a few more members of the forum respond before you go & do anything. They may have some better suggestions than I do.
Reply With Quote Quick reply to this message
  #3  
Old 08-04-2008, 09:28 AM
Compression Ignition Addict
 

Join Date: Sep 2006
Location: Mass
Posts: 237
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
One thing that might help diagnose #2 is, the blinker works fine when hooked up to a trailer?
#1 is solved. After Changing a rear caliper and bleeding the lines i noticed alot more tension on the ebrak cable on one side then the other, sprayed some WD-40 on it couple taps with a hammer and it free'd right up causing the light to go off
Reply With Quote Quick reply to this message
  #4  
Old 10-14-2009, 12:14 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Victor, ID
Posts: 427
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Did you ever figure out your windshield wipers? Mine have done the same thing since I bought the truck 3 years ago, and I'm hoping I can figure out what it is!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:25 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors