Flasher relay... - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 06-29-2008, 04:45 PM Thread Starter
Powerstroke.org Rookie
 
Dafiveo's Avatar
 
Join Date: Sep 2007
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Flasher relay...

A month or so back i kept hearing this buzzing noise from under my dash. When i would use the blinkers or touch the brakes, it would stop. Release the brakes or turn off the blinkers and it would stop again. I got to looking and found the little buzzing blue relay. I assumed it had just gone bad. I went to ford and paid 30 bucks for a new one. Put it in and it worked fine. No buzzing. Well 2 weeks went by and it started again! WTF? What would be messing the relays up and especially in this short period of time?? And is there any place to get the relay any cheaper than the dealership? I tried advanced auto parts and they said it was a dealer only part...
Dafiveo is offline  
post #2 of 5 Old 07-08-2008, 12:53 PM Thread Starter
Powerstroke.org Rookie
 
Dafiveo's Avatar
 
Join Date: Sep 2007
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
come on guys... i cant be the only one that has had this problem
Dafiveo is offline  
post #3 of 5 Old 07-17-2008, 12:37 PM
Powerstroke.org Rookie
 
Join Date: Jun 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I had the relay go out on me, buzzing followed, replaced relay all is good.

I would venture to say that you have a short in the wiring.
TimsTruck is offline  
post #4 of 5 Old 09-12-2008, 03:18 PM
Powerstroke.org Rookie
 
Join Date: Nov 2007
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have the same buzzing under the dash it started last week when I evacuated for hurricane Gustav. On the way home later that week it stopped and didn't happen again till this morning now happening all the time. I will try the blue relay.

Thanks
ssquire37 is offline  
post #5 of 5 Old 09-12-2008, 03:34 PM
Premium Member
 
deere4440's Avatar
 
Join Date: Jun 2007
Location: Remington, Indiana
Posts: 305
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My truck did the same thing to me last week, i replace the blue relay, still buzzed like crazy. Took it to a Ford Dealer, and they told me that my multifunction switch went bad and needed replace. Got it replaced and no more buzzing. You could try that.

Multifunction Switch a.k.a turn signal lever on the column.

2002 F-350 CC SB 7.3
MBRP 4 in straight pipe
AIS Intake
Foil Delete
Factory Tech Valve Body
203 Thermostat
Fog Light Mod
6k HID's from DDM

TOTALED!! 1/6/2009
2003 F-250, 7.3 FX4

deere4440 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome