Need advice on IDM and Injector Problems - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 07-15-2013, 03:03 AM Thread Starter Rookie
Join Date: Jul 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Need advice on IDM and Injector Problems

We have a 2002 F550 7.3 with a ghost problem. Sorry to ask you guys I'm sure it has been discussed before. I am an American in Norway. They do not sell these trucks here from the dealer so some of the computers are not available.

We replaced the motor and all hard parts.
Cylinder 8 and 3 are not firing. And then another time it is 2 and 6. We are getting random misfires on the injectors.

We replaced the injectors again which are already new and same problem. We have replaced the IDM and connection harness under valve covers and does not help. We replaced the harness under the valve cover and reinstalled/checked connection 3 times now.
We have tried this IDM on another truck and works fine. We have tried 3 different IDM's and same problem each time.
The PCM has been reflashed/ reset...No help.
All the relevant sensors have been replaced and re replaced. Ground has been replaced and checked.
We are pulling a constant 1316 code. Occasionally we are pulling 1670 code.

Fuel pressure is good. Oil pressure is good.

Any advice you guys could give me would be greatly appreciated. We have tried everything we know of and here in Norway we are cut off from dealer diagnostic help.

Thanks, Allen
adrtree is offline  
Sponsored Links
post #2 of 3 Old 07-15-2013, 06:33 AM
Compression Ignition Addict
MSTR-P's Avatar
Join Date: Sep 2008
Location: Southern MD
Posts: 632
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Sounds like you have done a ton of troubleshooting. Do you have access or can you get access to the AE Total Ford Bundle software? You need to have something to read deeper into the IDM and figure out what is causing that 1316 code.

'03 7.3 - Stock!

MSTR-P is offline  
post #3 of 3 Old 07-19-2013, 04:58 PM
Join Date: Sep 2011
Location: waupun, wi
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i read your post fast. But check your plug that plugs into your IDM. Make sure there is no corrosion. When i replaced mine i had a new plug put in because of the amount of corrosion that was there. May be a place to start.

2003 Ford F-350
7.3 Powerstroke!
8 inch BDS lift.
4 inch MBRP Exhaust
Edge Juiced w/ Attitude.
40 inch tires on 20 inch Black Moto Metals.
Preston16 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome