Fast!! then not so fast.?not consistant - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-16-2008, 02:32 PM
Member
 

Join Date: Feb 2008
Location: ogden area
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fast!! then not so fast.?not consistant

so i just got done doing my headgaskets and it went well but it still felt like it was falling on its face at full pedal. i wondered if it was boost? or the wastgate letting it out cus it almost sounded like that but my gauge still reads it all the way up to just under 25 pounds. wich i think is right?

well i put in my chip anyway edge with moniter. and the first night it scram! i couldnt believe how fast it was. but the next few days it felt almost like losing boost again and was slower. still quick but not the same. then it sometimes takes off fast but not consistant. it also sometimes runs a little rough at certain rpms?

just curious if anyone has any ideas why its doin it? or had similiar problems
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-29-2008, 04:39 PM
Powerstroke.org Rookie
 

Join Date: Apr 2008
Location: Athens
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Having the same problem with the inconsistant throttle! what is there to do?

Edge Evolution set at 80 horse.
4 inch exaust, turned out infront if rear wheel.
4 inch lift with 35in tires.
overboost eliminator.
And turbo has been worked on, its boosting 29lbs.

Last edited by crazykyker; 04-30-2008 at 01:30 PM.
Reply With Quote Quick reply to this message
  #3  
Old 04-29-2008, 04:51 PM
Cynic
 

Join Date: Jun 2007
Location: Fort Worth, Texas
Posts: 11,194
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Can you list your year and mods?

Also, have you tried pulling codes?
Reply With Quote Quick reply to this message
  #4  
Old 04-30-2008, 06:34 AM
Member
 

Join Date: Feb 2008
Location: ogden area
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
hey dirk looks like youv been helpin me in my other thread. thanks! i thought this one was dead!

i have pulled the codes and in fact had the number 4 injector replaced it almost seemed to make my miss/funny knock worse. they told me number 8 injector was reading now. so i told them i would do it myself. so i got a injector for that but am not confident its worth my time to put in. (but maybe just to make sure there is a shiny new one in number 4)ha. anyway thats really it.

mods are. Ford performace intake,4" turbo back,edge with atitude chip.

my service engine soon light that comes on when you nail it with a edge chip seems to come on with less throttle than it used to ,. thats because of fuel of somethin isnt it?
Reply With Quote Quick reply to this message
  #5  
Old 04-30-2008, 06:35 AM
Member
 

Join Date: Feb 2008
Location: ogden area
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
oh ya and 02 motor in pre 99 truck! haha
Reply With Quote Quick reply to this message
  #6  
Old 04-30-2008, 06:58 AM
Cynic
 

Join Date: Jun 2007
Location: Fort Worth, Texas
Posts: 11,194
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
You really need to run a compression test. How many times did you run the contrib/balance test? You should be around 400psi or higher. If your compression is good, and you keep dropping injectors.. you need to look at your mileage. Orings are known to fail randomly on motors over 100-150K.
Reply With Quote Quick reply to this message
  #7  
Old 04-30-2008, 01:40 PM
Powerstroke.org Rookie
 

Join Date: Apr 2008
Location: Athens
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Edge Evolution set at 80 horse.
4 inch exaust, turned out infront if rear wheel.
4 inch lift with 35in tires.
overboost eliminator.
And turbo has been worked on, its boosting 29lbs
Reply With Quote Quick reply to this message
  #8  
Old 04-30-2008, 03:51 PM
Cynic
 

Join Date: Jun 2007
Location: Fort Worth, Texas
Posts: 11,194
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by crazykyker View Post
Having the same problem with the inconsistant throttle! what is there to do?

Edge Evolution set at 80 horse.
4 inch exaust, turned out infront if rear wheel.
4 inch lift with 35in tires.
overboost eliminator.
And turbo has been worked on, its boosting 29lbs.
Start a thread listing your truck and issues and any codes you've pulled. I won't be able to keep track of multiple trucks in one thread.

Sorry.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:18 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors