very poor MPG IMO... possible causes - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 05-29-2013, 06:57 AM Thread Starter
Compression Ignition Addict
 
Join Date: Apr 2008
Location: San Antonio
Posts: 198
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
very poor MPG IMO... possible causes

So i bought this supercrew short bed 4X4 because it figured id get similar MPG as my 99 extended cab long bed. Boy was i wrong. went on a trip to Corpus Christi from san antonio and averaged about 14 MPG highway!!!

compared to the other truck which consistently has given me 19-20 on the same trip.

tires are toyo- open country, suspension is all stock.

the truck has AFE stage 2 intake and was on bully dog street tune, same as the other truck.

the only difference ive noticed is even after alignment this truck shakes a bit when you get to almost 40 mph, and slowly the vibration goes away at higher speeds. also at idle this truck sounds a bit lopey at times, not smooth like the other truck...

any help? thinking about selling this truck already.
Attached Thumbnails
Click image for larger version

Name:	99 F250 4X4 1.jpg
Views:	233
Size:	95.2 KB
ID:	117841  

My DD and Work Truck
'99 F250, ext cab, long bed
Bully Dog 6 pos switch
AFE stage II intake
guages
stang_1973 is offline  
post #2 of 3 Old 06-04-2013, 11:17 AM
Compression Ignition Addict
 
blue99stroker's Avatar
 
Join Date: Oct 2011
Location: Chico, California
Posts: 4,950
Thanks: 18
Thanked 210 Times in 201 Posts
Mentioned: 1 Post(s)
Quoted: 135 Post(s)
Feedback Score: 0 reviews
id say oil or fuel pressure could be the causes of the romps.
pull the ICP sensor see if theirs oil coming through.
then possibly IPR.
lastly check fuel pressure.

99.5 f250 7.3 4x4 258k
PHP Phoenix, S&B CAI, 4" TBE, Hpx, Stancor, RR Billet Wheel, AIH Delete, Autometer Gauges, Leveling kit, Transgo kit, Warn Hubs, Int'l Up-Pipes, RR IC Boots, Non-Ebpv Pedestal, High Flow Outlet, RR OCR, 08 Tow Mirrors.

Dad-2000 7.3 109k miles, Autometer Gauges, Superchips 1705, AIH Delete, 6637, 4" TBE, BD Billet Wheel, TruCool Max
blue99stroker is offline  
post #3 of 3 Old 06-07-2013, 05:33 PM
Powerstroke.org Fanatic
 
Join Date: Sep 2011
Location: Tri ****ties, WA
Posts: 133
Thanks: 1
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
exhuast back pressure sensore and tube

maybe your bearings are bad, causing drag?

does it have the same gears as the last truck? did the rpms seem high?

that sucks man i get 12-13 but im pushing 38's,

i dunno about the tuner, could be part of the problem, ive never heard anything good about bullydog

_________________________________________
02 f350, AFE stage 2 intake, wicked wheel, edge
evolution, performance authority trans, 10" lift 38's
with 4:56's, C2 gauges, 4" turbo back AERO muffler
TD444EVER is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome