All 4 brakes locked up!! Help!! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 05-27-2013, 11:12 AM Thread Starter
Powerstroke.org Rookie
 
atgreene's Avatar
 
Join Date: Oct 2012
Location: Columbia, MO
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
All 4 brakes locked up!! Help!!

99 f250 7.3 174k
When I was parking today my brake Pedal went hard and my brakes locked up. I really had to give it a lot of throttle to move. Parked it hoping it would be better when I returned. Same thing. Drove it home and all four corners were smokin hot and steaming. I also noticed it gets worse when I turn. If you drive, say one mile without braking, then the brakes gradually let off, but as soon as you hit the brakes again, same thing. They lock up. I've been reading that the power steering and brake system are connected via hydrobooster. About 4 months ago I topped off the PS system with PS fluid instead of ATF. Could this be causing my problem. I haven't had any problems prior to this, oh except when I make sharp turns I would notice the brake pedal become stiffer and the brakes we sticking.
What should I do?
Since its all four corners I'm leaning towards booster or master cylinder.
Should I do a PS system flush and put new ATF in?

Thanks!
atgreene is offline  
post #2 of 4 Old 05-27-2013, 12:20 PM Thread Starter
Powerstroke.org Rookie
 
atgreene's Avatar
 
Join Date: Oct 2012
Location: Columbia, MO
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i just went out to test the PS and it sucked. so say my PS pump is bad, would that cause all 4 of the brakes to lock up?
im puzzled on this one
atgreene is offline  
post #3 of 4 Old 05-28-2013, 08:54 PM
Powerstroke.org Sponsor

 
Corey@CNCFAB's Avatar
 
Join Date: Apr 2010
Location: Defiance, OH
Posts: 9,664
Thanks: 803
Thanked 535 Times in 489 Posts
Mentioned: 201 Post(s)
Quoted: 516 Post(s)
Feedback Score: 1 reviews
Putting PS fluid in it killed your hydroboost seals and prolly you PS pump. That Sux. Hydroboosters are not cheap.

Sent from AutoGuide.com Free App

E99CCLB 450/400s,STG1cam, KC38R, 4" exh,CNC FAB fuel&oil lines,140vIDM,BTS,S&B

97 ECLB F250 4x4 stock
96 CCLB F350 4x4 stock



EDGE,S&B,SCT,PHP Hydra,TS-Perf,OEM parts,Sam Wyse trans,VB's,LED's,MBRP,ISSPRO,ICON,FOX,KC TURBOs,SD 7.3 fuel kits, HPOP lines

www.cncfab.us or email sales@cncfab.us

Corey@CNCFAB is offline  
post #4 of 4 Old 05-29-2013, 05:47 PM Thread Starter
Powerstroke.org Rookie
 
atgreene's Avatar
 
Join Date: Oct 2012
Location: Columbia, MO
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
checked ps fluid and turns out it was just low, i did a flush with fresh atf and everythings back up and running. im lucky it didnt fry the pump. now just need to make sure there is no leak.

lesson learned: check fluids often & if all your brakes lock up, then check the ps fluid
atgreene is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome