No brake Lights! Help!!!! - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 05-12-2013, 08:20 PM Thread Starter Rookie
Join Date: May 2013
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No brake Lights! Help!!!!

Hey guys new to the forum, been reading the forums for weeks tho, excellent place, i love it. i have a dilemma here on my 1/99 250 powerstroke. Not sure how long its been this way but i noticed i do not have ANY brake lights, this is including the third light on the cab. But my signals, hazards and running lights work fine. I figured id start at the brake switch, bought a new one replaced the old and no change. next i decided to take the multifunction switch out, clean up the guts inside of it, and throw it back in, No change... All fuses have been checked, bulbs are new. Any ideas?! i plan on going out there tomorrow with a test light to see whats going on but maybe someone here has gone thru this before. Also note that i did replaced the rear bumper last week, i had to hard wire the licence plate lights to the running lights, but this is still working and i was no where near the wires to the actual brake light. Do the Turn signals share the same wire as the brake lights? anyone have any input on this would be grateful! thanks guys!
Masterjqx is offline  
Sponsored Links
post #2 of 2 Old 05-17-2013, 04:59 AM Rookie
HogginNboggin9's Avatar
Join Date: Oct 2012
Location: Mt. Carmel
Posts: 16
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
do you kno if this happened right after you replaced the bumber? if so i would be looking for a broken/pinched wire. and test the fuses with a test light, fuses can be decieving sometimes when just pulling and looking at them. ive a couple times thought i had a good fuse looking at it then while testing it turned out to be a bad one. hope this helps

-04 f250 6 leaker
Skyjacker 4 inch lift,MBRP 5in Straight Pipe,03 turbo,ipr gen 2 egr delete,sinister coolant filter,blue spring mod, autometer gs guages pyro,boost,fuel psi,scanguage2, SCTx3 tunes from idp,no studs yet.
-96 f150 5.0
Superlift 8 inch lift,SAS 8 lug conversion,38.5 boggers,Mazda 5 speed stick shift swap from auto.
-HAD a 2000 7.3 dp-tuner,ATS Housing,leveling kit, MBRP 4in Straight Pipe,guages pyro,boost,trans temp,Stancor Mod,napa 6637. Traded it for my 6.0
HogginNboggin9 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome