computer gone bad? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 02-25-2008, 02:14 PM Thread Starter
peyton7522's Avatar
Join Date: Apr 2007
Posts: 77
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
computer gone bad?

it was about 2 weeks ago my truck was idleing in the drive way and i hopped in the truck and i have a ts performance chip that kinda hangs down and when i hopped in the truck i pulled it out with my foot on accident and the whole truck shut off and wouldnt crank back up. i got it taken to the dealership and they said that i needed a new computer why did this happen anyone. help. 99 7.3l powerstroke. ts performance 6 pos chip.
peyton7522 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome