Glow Plug Issues - Ford Powerstroke Diesel Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 02-12-2013, 05:43 PM Thread Starter
Compression Ignition Addict
 
RAMKILLER97's Avatar
 
Join Date: Sep 2011
Location: Hull, MA
Posts: 298
Thanks: 3
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Glow Plug Issues

So I have been getting a p0683 (GPCM GPCM glow plug control module communication line failure Open/shorted circuit, failed GPCM, failed PCM)
in my truck for a couple weeks now. I will clear it and it comes back a couple days later. Also it it giving me different failed glow plug codes. I have gotten 1,5, and 8 I believe. The truck starts more rough than normal on cold starts and blows white smoke for a bout 10 seconds then clears up and idles smooth but on warmer days starts fine. Noticed it running a little rougher today but wasnt bad by any means, could just have been me though. Truck has 183xxx miles on it and probably has never had the plugs changed. Probably changing them thursday but that p0683 has me worried becuase I dont have another $200 to drop on a pcm or gpcm after my water pump decided to implode last week. I could use some advice. Thanks.

-Rob

2003 Excursion Eddie Bauer 7.3
6 Inch ProComp Lift, 315/75/16 BFGoodrich All Terrain Tires, BTS Transmission, 175/100 P.I.S. Injectors, PMF Traction Bars, Garrett 38r, International Up Pipes, Dyno Proven Tunes, 6.0 Transmission Cooler, CCV mod, MBRP 4" Turbo-Back Exhaust, RiffRaff Over Boost Code Regulator, Moto Metal MO951 Black Rims, Dual Sky Jacker Steering Stabilizers, GlowShift Gauges, Mile Marker 449SS Lockout Hubs, 6637 Intake.

Putting this old PMR truck to the test....
RAMKILLER97 is offline  
post #2 of 4 Old 02-18-2013, 05:27 AM
Powerstroke Junkie


 
NCHornet's Avatar
 
Join Date: Aug 2006
Location: Mayberry, NC
Posts: 8,308
Thanks: 0
Thanked 51 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
STOP!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!

Before tossing money at the problem how about proper diagnoses first? Follow the write up at the top of this section and check the GPR and then ohm the GP's through the UVC harness and check for a good connection and I believe by doing this your problem will be obvious and you won't waste your cash. If plugs are bad only use Beru's.

NCH
Proud Father of USAF Airman


2000 F350 DRW,CC,LB, 4X4, Western Hauler Pkg.
Ford AIS/ BTM, FTVB
My CCV MOD, Coolant filter
06 Grill, 05 lights,6.0 trans cooler
Cyro/Hawks, JVC Touchscreen HU, JL C5's, Infinity 800watt amp,
DP tunes, 60 tow/80 e/120 race, on a SCT2 tuner
P3 controller, Brite Box Turbo Lifesaver
KMC Wheels x 4

http://s132.photobucket.com/user/NCH...=recent&page=1

Friends Don't Let Friends Drive Trucks With Generic Tunes
NCHornet is offline  
post #3 of 4 Old 02-18-2013, 11:58 AM Thread Starter
Compression Ignition Addict
 
RAMKILLER97's Avatar
 
Join Date: Sep 2011
Location: Hull, MA
Posts: 298
Thanks: 3
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hahaha, well so far I have done nothing to the truck. I bought motorcraft plugs but haven't put them in yet. I talked with my dad and we are going to work on it sometime next week when I see him. I mean the truck has 183xxx on it so it could probably use plugs soon anyways. But we were going to check the connection on the UVC gasket before pulling anything. But to my knowledge I thought the Excursions didn't use a GPR but instead used a GPCM because it uses the same emissions stuff as a california truck?

2003 Excursion Eddie Bauer 7.3
6 Inch ProComp Lift, 315/75/16 BFGoodrich All Terrain Tires, BTS Transmission, 175/100 P.I.S. Injectors, PMF Traction Bars, Garrett 38r, International Up Pipes, Dyno Proven Tunes, 6.0 Transmission Cooler, CCV mod, MBRP 4" Turbo-Back Exhaust, RiffRaff Over Boost Code Regulator, Moto Metal MO951 Black Rims, Dual Sky Jacker Steering Stabilizers, GlowShift Gauges, Mile Marker 449SS Lockout Hubs, 6637 Intake.

Putting this old PMR truck to the test....
RAMKILLER97 is offline  
post #4 of 4 Old 03-05-2013, 04:46 PM Thread Starter
Compression Ignition Addict
 
RAMKILLER97's Avatar
 
Join Date: Sep 2011
Location: Hull, MA
Posts: 298
Thanks: 3
Thanked 4 Times in 4 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Well I figure I will post what the issue was. My entire drivers side bank of plugs threw me codes even after they had been replaced so we changed the GPCM and that solved that side (also it looked like one of the plugs on the module was burnt out), but the passengers side was still giving me codes on numbers 1 and 5. Changed all the plugs on that side and that solved that issue so now I am all squared away and she cranks over so much easier.

2003 Excursion Eddie Bauer 7.3
6 Inch ProComp Lift, 315/75/16 BFGoodrich All Terrain Tires, BTS Transmission, 175/100 P.I.S. Injectors, PMF Traction Bars, Garrett 38r, International Up Pipes, Dyno Proven Tunes, 6.0 Transmission Cooler, CCV mod, MBRP 4" Turbo-Back Exhaust, RiffRaff Over Boost Code Regulator, Moto Metal MO951 Black Rims, Dual Sky Jacker Steering Stabilizers, GlowShift Gauges, Mile Marker 449SS Lockout Hubs, 6637 Intake.

Putting this old PMR truck to the test....
RAMKILLER97 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome