air bag - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 10 Old 12-12-2007, 11:17 AM Thread Starter
zac
Powerstroke.org Rookie
 
zac's Avatar
 
Join Date: Aug 2007
Location: mesa
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
air bag

my air bag light has been on for awhile, just wondering if any one elses is on or if any one has had probs with theirs?
zac is offline  
Sponsored Links
Advertisement
 
post #2 of 10 Old 12-12-2007, 11:33 AM
KVFD
 
redstroker_2002's Avatar
 
Join Date: Nov 2007
Location: Kearney, Nebraska
Posts: 4,061
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to redstroker_2002
is it pushing any codes out maybe check that! then get back with us!

-Josh

2008 2500 LMM- Deleted, Blocked, Fueled, & Tuned by:
redstroker_2002 is offline  
post #3 of 10 Old 12-12-2007, 05:54 PM Thread Starter
zac
Powerstroke.org Rookie
 
zac's Avatar
 
Join Date: Aug 2007
Location: mesa
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have plugged in a scanner before and it doesn't even power it up, plugged it into my uncles dodge and it worked how it should. any ideas?
zac is offline  
post #4 of 10 Old 12-12-2007, 05:58 PM
Compression Ignition Addict
 
-diesel-'s Avatar
 
Join Date: Dec 2007
Posts: 455
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
The fuse that powers the ALDL is also the fuse for the power outlet in the dash. If it's blown the scanner will not power up.



2KRCSB2WD73335750
-diesel- is offline  
post #5 of 10 Old 12-17-2007, 02:37 PM Thread Starter
zac
Powerstroke.org Rookie
 
zac's Avatar
 
Join Date: Aug 2007
Location: mesa
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the power port works fine, so i don't know where to look. I might have to take it to ford and let them mess with the plug and the airbag issue. i'm lost with the fuse and relay locations because when i bought the truck it didn't have the owners manual.
zac is offline  
post #6 of 10 Old 12-17-2007, 02:41 PM
Compression Ignition Addict
 
cocowboy's Avatar
 
Join Date: Dec 2007
Location: Tulsa
Posts: 206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a 99' explorer that I got from my grandparents in high school. It had the air bag light on when I got it and didn't throw any codes either. To this day it is still on, and I have had 3 different mechanics look at it and none could figure it out.
cocowboy is offline  
post #7 of 10 Old 12-17-2007, 06:26 PM
Berm Buster

 
Speedyboy487's Avatar
 
Join Date: Nov 2007
Location: Angelica, NY
Posts: 527
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My air bag light was on. It flashed 2 times then a pause and would flash 7 times. then after about 4 cycles would stay on. The passenger air bag light bulb was blown. took about 2 dollars and 20 mins to fix.

2002 F-250 7.3L 4x4,6 Speed,Hyperpac, MBRP 4”dp5” K&N/DIY Intake, Foil Delete, Rough Country leveling kit, 305/70/16 Dunlop Mud Rover
Autometer Ultra Lite ll Pyro Boost- TW tunes

Last edited by Speedyboy487; 12-17-2007 at 09:07 PM.
Speedyboy487 is offline  
post #8 of 10 Old 12-18-2007, 05:47 PM Thread Starter
zac
Powerstroke.org Rookie
 
zac's Avatar
 
Join Date: Aug 2007
Location: mesa
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I even took the whole switch from a buddies truck put it in mine, put mine in his. mine worked in his truck , but his didn't work in mine. light still works(out of my truck). i am not that lucky with the inexpensive easy fixes. i would just unplug the darn switch, that stops the warning light but i don't know if that would keep if from blowing in an accident. if i was sitting in the pass side thats what i would do, but my wife rides there. i'm leaning towards a relay or some thing like that, was it the light in the switch?
zac is offline  
post #9 of 10 Old 12-18-2007, 09:25 PM
Berm Buster

 
Speedyboy487's Avatar
 
Join Date: Nov 2007
Location: Angelica, NY
Posts: 527
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yes. take the dash out then take the 3 screws out i think they were 5.5mm. take the top plastic piece off the switch and the bulb is right there. but if it worked in another truck i dont see how that could be the problem. wouldnt hurt to check i guess. normaly a bulb is eather blown or its fine. Did you price a new switch? you could have ford scan it. they wanted 109$ to scan mine.

2002 F-250 7.3L 4x4,6 Speed,Hyperpac, MBRP 4”dp5” K&N/DIY Intake, Foil Delete, Rough Country leveling kit, 305/70/16 Dunlop Mud Rover
Autometer Ultra Lite ll Pyro Boost- TW tunes
Speedyboy487 is offline  
post #10 of 10 Old 12-20-2007, 02:47 PM Thread Starter
zac
Powerstroke.org Rookie
 
zac's Avatar
 
Join Date: Aug 2007
Location: mesa
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i took it all apart again today. swaped the switches again, really paid attention to what the results were. Both switches worked in his truck, not in mine. tested ohms, wires etc. was about to put it back together and thought id take the lower dashpanel off, to trace wires from the airbag control module to the PAD switch and i found a broken wire, got all excited because it is the wire for the Pad switch. connected it and nothing. My mechanic buddy and I scanned it and it gave us two codes. B1871 and B1890. He is gonna research some more but hes leaning towards some type of wiring issue. there was one broke wire so there maybe more( hopefully just broken wires)
zac is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome