Getting BAD fuel milage.... - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 12-12-2007, 07:55 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Oct 2007
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Getting BAD fuel milage....

I have a 2000 F-250 4x4 with a 7.3 and automatic tranny. I have installed an AEM Cold Air Intake, MBRP 4" Turbo Back Exhaust and an Edge Products Evolution Programmer. I am only getting around 12 miles per gallon. On a recent trip from Denver to California and back pulling an enclosed motorcycle trailer, about 3000 lbs. at the most I still only averaged 12 miles per gallon. What is the deal ???? PLEASE HELP !!!

Scott

Last edited by MeNotn2BS; 12-12-2007 at 07:59 AM.
MeNotn2BS is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 12-12-2007, 08:23 AM
Thats Mr. Oil Leak.....

 
MrJohnWayne's Avatar
 
Join Date: Oct 2006
Location: Waller/Magnolia
Posts: 9,598
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 9
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
could be the winter blend fuel. that and the ULSD have been dropping mpg's

When was your last fuel filter change? Have you by chance run any kinda of bio? even the b5 will "clean" the fuel system and turn the filter black with one tank.

John Wayne
Owner and Operator of the
REDNECK VALDEZ
You can find me on FaceBook
MrJohnWayne is offline  
post #3 of 6 Old 12-12-2007, 08:37 AM
Powerstroke Techie

 
Clay Henry's Avatar
 
Join Date: Jul 2006
Location: Tuttle, OK
Posts: 17,212
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 1
Thanked 13 Times in 11 Posts
Feedback Score: 0 reviews
How fast were you driving?

2003 6.0 F350 dually on high cholesterol fuel (WVO)
2000 7.3 Excursion also on a high cholesterol fuel



Clay Henry is offline  
post #4 of 6 Old 12-12-2007, 03:04 PM
Powerstroke.org Fanatic
 
Join Date: Jan 2007
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by MeNotn2BS View Post
I have a 2000 F-250 4x4 with a 7.3 and automatic tranny. I have installed an AEM Cold Air Intake, MBRP 4" Turbo Back Exhaust and an Edge Products Evolution Programmer. I am only getting around 12 miles per gallon. On a recent trip from Denver to California and back pulling an enclosed motorcycle trailer, about 3000 lbs. at the most I still only averaged 12 miles per gallon. What is the deal ???? PLEASE HELP !!!

Scott
I would say, pulling an enclosed trailer (wind resistance), at elevation and through the mountains(Denver to Cali.), and using winter blend fuel (I lose 1-1.5 mpg in the winter), I would say you are not too far off of normal mpg's.
Try changing your fuel filter and try some fuel additive.

2000 F350 Crewcab 4x4 7.3l with AFE stage II, MBRP 4" turbo back, Turbonetics "Quick spool" turbo with .84 housing, DP Tuner chip, 80 tow,80 econo, 120 race.
D-man is offline  
post #5 of 6 Old 12-12-2007, 03:13 PM
Powerstroke.org Fanatic
 
Join Date: Jan 2007
Posts: 138
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
What size tires do you run?
I gained 2 mpg (unloaded) with a DP tuner chip. You might want to invest.

2000 F350 Crewcab 4x4 7.3l with AFE stage II, MBRP 4" turbo back, Turbonetics "Quick spool" turbo with .84 housing, DP Tuner chip, 80 tow,80 econo, 120 race.
D-man is offline  
post #6 of 6 Old 12-13-2007, 03:48 PM
Powerstroke.org Rookie
 
clevif's Avatar
 
Join Date: Dec 2007
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Im running 33 x 13.50 tires a superchip 5 inch exhaust and an air raid intake on an '03 7.3 and all yr long all i get is about 12-13.5. So dont feel to bad
clevif is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome