electrical issue in a 2002 f250 - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-05-2013, 08:18 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Location: iowa
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
electrical issue in a 2002 f250

I'm tryin to help a guy out and fix the starting problems on his sons psd. after work on the side. I have no books on this unit at all and the 2002 seems to be it's own breed of cat.
I have found the grounds at the three pins at the pcm go open with the key on.Is this normal? last i knew a ground wire was grounded at all times. This is g101 in wich i am referring to. the pcm was bad-had a burnt transister in it. 4wd module was burnt also.
as a side note, the dome lamps dont work either.

originally thought there was a problem with the glow plug system but the pcm is not activating the glow plug relay. i have printed a lot of material from ford, but there is no symptom code for this concern that i can find.
The idm relay also buzzes continuously with the key in the key in the on position.

PLEASE guys, point me in the right direction.

Last edited by dusty14319; 02-05-2013 at 08:23 PM. Reason: just remembered
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-05-2013, 08:25 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,589
Thanks: 5
Thanked 102 Times in 97 Posts
Feedback Score: 2 reviews
Does the wait to start light come on?
Reply With Quote Quick reply to this message
  #3  
Old 02-05-2013, 08:27 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Location: iowa
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
glow plug light stays on continuously.
Reply With Quote Quick reply to this message
  #4  
Old 02-05-2013, 08:31 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 12,589
Thanks: 5
Thanked 102 Times in 97 Posts
Feedback Score: 2 reviews
That is different. I don't have any idea on that one.
Reply With Quote Quick reply to this message
  #5  
Old 02-06-2013, 07:40 AM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 4,886
Thanks: 1
Thanked 89 Times in 84 Posts
Feedback Score: 3 reviews
When my '02 had the "buzzing IDM relay" it was a connector HERE-> POTENTIAL ELECTRICAL CORROSION if your truck is like mine......
Reply With Quote Quick reply to this message
  #6  
Old 02-06-2013, 07:50 AM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Location: iowa
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
already been there and it was fixed by someone else. i am more concerned about the ground issues at the pcm.
Reply With Quote Quick reply to this message
  #7  
Old 02-08-2013, 04:27 PM
Powerstroke.org Rookie
 

Join Date: Feb 2013
Location: iowa
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
G101 was not connected properly.

Last edited by dusty14319; 02-08-2013 at 04:28 PM. Reason: mistake
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:48 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors