7.3L electrical mystery-any suggestions? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-06-2007, 08:48 AM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
7.3L electrical mystery-any suggestions?

My 2002 7.3L diesel did something very strange last night. Since the low temps have been in the 20's at night, the battery light on the instrument panel lights up after first starting and stays on until I've driven for a while. Batteries are 3 months old. Yesterday, the battery light never went off. After driving about 15 miles, the engine hesitated (its done this before) but didn't die. 10 miles later, the engine died just as I got to my friends house. It quickly restarted, but I turned it off and parked it for about 3 hours. Restarted engine, battery light on again, drove 10 miles, ABS light comes on, headlights start to dim, kept driving, eventually radio shuts off, power windows don't work, O/D light starts flashing, headlights getting dimmer and dimmer. Decided to drive to a safer place in case engine dies again. When I made a left turn, all the electrical components suddenly started working again! Drove home but battery and ABS light still on. What do you think is going on? Alternator (have 2), CPS, something with wiring?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-06-2007, 08:54 AM
duct tape & zip ties

 

Join Date: Jul 2006
Location: Willis, MI
Posts: 10,759
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Have your Alternator tested. It maybe bad. I would start there. Also check and clean the battery connections. Also what size batteries did you install.
Reply With Quote Quick reply to this message
  #3  
Old 12-06-2007, 09:24 AM
Powerstroke.org Rookie
 

Join Date: Dec 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I installed a couple of Duralast Golds with 875 CCA each.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:48 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors