7.3L electrical mystery-any suggestions? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-06-2007, 09:48 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
7.3L electrical mystery-any suggestions?

My 2002 7.3L diesel did something very strange last night. Since the low temps have been in the 20's at night, the battery light on the instrument panel lights up after first starting and stays on until I've driven for a while. Batteries are 3 months old. Yesterday, the battery light never went off. After driving about 15 miles, the engine hesitated (its done this before) but didn't die. 10 miles later, the engine died just as I got to my friends house. It quickly restarted, but I turned it off and parked it for about 3 hours. Restarted engine, battery light on again, drove 10 miles, ABS light comes on, headlights start to dim, kept driving, eventually radio shuts off, power windows don't work, O/D light starts flashing, headlights getting dimmer and dimmer. Decided to drive to a safer place in case engine dies again. When I made a left turn, all the electrical components suddenly started working again! Drove home but battery and ABS light still on. What do you think is going on? Alternator (have 2), CPS, something with wiring?
Outdoorsman07 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-06-2007, 09:54 AM
duct tape & zip ties

 
bigcountrysg's Avatar
 
Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Have your Alternator tested. It maybe bad. I would start there. Also check and clean the battery connections. Also what size batteries did you install.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Your Actions Today, Decide Your Future Tomorrow

2005 6.0 Crew Cab Long Box Lariat, current truck

2004 6.0 destroyed by contaminated fuel

2002 7.3L burnt
bigcountrysg is offline  
post #3 of 3 Old 12-06-2007, 10:24 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I installed a couple of Duralast Golds with 875 CCA each.
Outdoorsman07 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome