fuel help! - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-04-2013, 04:47 PM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2011
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
fuel help!

checked the fuel pressure at it was about 35 at the bowl so i took off the tube where it fills with the spring at the top of the fuel bowl to check the spring and its all good so i screwed it back together and now no fuel is flowing through that port. the bottom of the tank is filling out of the lower port.. whats making one fill and the other not?
travis182008 is offline  
post #2 of 6 Old 02-05-2013, 04:54 AM
Member
 
whitextreme's Avatar
 
Join Date: Sep 2006
Location: Philadelphia, PA
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The port at the top with the spring is the return to the tank.
whitextreme is offline  
post #3 of 6 Old 02-05-2013, 06:52 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2011
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
oh ok. i didn't know if they both filled it or just the lower port.. i thought i have seen the top port filling it with fuel. i must be wrong. i just can't get the truck to prime. have low fuel pressure
travis182008 is offline  
post #4 of 6 Old 02-05-2013, 11:04 AM
Member
 
whitextreme's Avatar
 
Join Date: Sep 2006
Location: Philadelphia, PA
Posts: 88
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Make sure you have a clean filter in there. And I assume you cleaned any junk out of the regulator when I was apart. But it could be a few things the pump could be weak, the spring in the regulator could be worn, or the screens in the tank could be clogged.
whitextreme is offline  
post #5 of 6 Old 02-05-2013, 11:26 AM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2011
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
ya i put a new fuel filter in there last night and looked at the regulator screen and it looks ok and a couple weeks ago put a new pick up in the tank i think its gotta be a bad pump..
travis182008 is offline  
post #6 of 6 Old 02-05-2013, 05:21 PM Thread Starter
Compression Ignition Addict
 
Join Date: Feb 2011
Posts: 195
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
i only have like a 1/8 th of a tank of fuel. its running but the fuel pressure is real low.. could this be because I'm low on fuel or should that not be the case and its probably my pump going to ****
travis182008 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome