2000 psd wastegate issue? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-01-2013, 07:25 PM
Powerstroke.org Fanatic
 

Join Date: May 2007
Location: va
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2000 psd wastegate issue?

hey guys i just bought a 2000 f350 4x4 dually 6 speed with 140k. stock only thing is a exhaust and a 60hp tow chip and no gauges..it runs great.. no leaks no codes. however if im wot it seems like the turbo isn't spooling and if i let out just a little and hold it.. the turbo starts spooling the truck pulls hard...im a obs kinda guy so now i gotta learn the nbs...could the wastegate be opening not allowing the turbo to spool...the tps? i checked all boots and im good on leaks.....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-01-2013, 07:56 PM
COME ON...ONE TIME!!


 

Join Date: Sep 2007
Location: Fletcher, NC
Posts: 16,751
Thanks: 68
Thanked 58 Times in 56 Posts
Feedback Score: 0 reviews
Re: 2000 psd wastegate issue?

Check fuel filter. Sound like afuel issue
Reply With Quote Quick reply to this message
  #3  
Old 02-01-2013, 08:02 PM
Powerstroke.org Fanatic
 

Join Date: May 2007
Location: va
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the day after i bought the truck i changed engine, tranny and transfer fluids and a new fuel filter.....the truck was well upkept i found a log of all maintenance records...
Reply With Quote Quick reply to this message
  #4  
Old 02-01-2013, 09:09 PM
Compression Ignition Addict

 

Join Date: Mar 2010
Location: hoquiam, wa
Posts: 852
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like your up pipes are leaking, i would take a look at those next
Reply With Quote Quick reply to this message
  #5  
Old 02-02-2013, 06:49 AM
COME ON...ONE TIME!!


 

Join Date: Sep 2007
Location: Fletcher, NC
Posts: 16,751
Thanks: 68
Thanked 58 Times in 56 Posts
Feedback Score: 0 reviews
It could be high pressure oil also. If there's not enough pressure made by the hpop, then you'll flatten out on full throttle. Check the boost leaks too along the up pipes.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors