Rock and roll idle - Ford Powerstroke Diesel Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 Old 11-20-2007, 03:15 PM Thread Starter
Compression Ignition Addict
 
powerplant's Avatar
 
Join Date: Sep 2007
Location: Eastern Ky
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Rock and roll idle

Early 99 idles rough when it wants to had been off and on 4 days ago started on way home. Check engine light on got home shut off .I was out of town for 4 days started truck and rough idle from start up first time for that one. a week ago it died going down the road but it will always start back up any ideas would a cmp sensor act like this. All fluids and filters are fresh and one more thing doesnt matter if it is cold out or 70 degrees like it was today. Thanks please help.
powerplant is offline  
post #2 of 12 Old 11-20-2007, 03:46 PM
BIG TRUCK, SMALL DRIVER
 
pipelayerjdh's Avatar
 
Join Date: Oct 2006
Location: Iva, SC
Posts: 5,877
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
It is never a bad idea to replace the CPS. If that doesn't get it, you can keep the old one for a spare.

Derrick

My photobucket




'97 F-350 "FORDOR" 4X4 (Dually Conversion, Shackle Reversal, Technicooler , Auto Meter Gauges, 4" DIY Dual Exhaust w/ '08 tips, 4" DIY intake w/ AEM filter, Wicked Wheel 2, 360° thrust bearing, Homemade E-fuel conversion, Wildman Chip, 160cc DIY injectors , DIY IDM mod) 230K and counting...
pipelayerjdh is offline  
post #3 of 12 Old 11-20-2007, 04:19 PM
Compression Ignition Addict
 
460+'s Avatar
 
Join Date: Oct 2007
Location: Liberty,In
Posts: 767
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Try cps and get codes unless thats how you got cps.

99 F350 4x4 dually
7.3 w/K&N af
4" exh into 6" Aussies stacks
4"lift &35" tires
CC mod HP crossover line
Beans stage II 120hp injectors
D66 turbo
ITP regulated return
reburn on TS= 25,high idle,60,100,120,140hp
updated ecm (2000 model)
Dyno#'s 360hp and 965 ft lbs trq
460+ is offline  
post #4 of 12 Old 11-20-2007, 04:45 PM Thread Starter
Compression Ignition Addict
 
powerplant's Avatar
 
Join Date: Sep 2007
Location: Eastern Ky
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Update went out started truck this is a hour later than the first post ok still idleing rough set there let it warm up and the hole time it was warming up i was settiing there in cab watching and filling just as soon as you would feel the idleing start to smooth out the check engine light goes out it will run smooth for a minute or a couple of minutes then it will start all over agin. Then i started out the drive way it smoothed out no light and drove like a champ drove it 10miles down the interstate no problems pulled back in garage turned it off started it backup no problem.Ill say im sorry first but it acts just like a women cant make its mind up Ha Ha.
powerplant is offline  
post #5 of 12 Old 11-20-2007, 04:48 PM Thread Starter
Compression Ignition Addict
 
powerplant's Avatar
 
Join Date: Sep 2007
Location: Eastern Ky
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
powerplant is offline  
post #6 of 12 Old 11-20-2007, 05:47 PM
Powerstroke.org Rookie
 
Join Date: Aug 2007
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
My 2000 did almost the exact same thing. Dealer replaced cps and all was well agian.
StrokerAZ is offline  
post #7 of 12 Old 11-20-2007, 07:03 PM Thread Starter
Compression Ignition Addict
 
powerplant's Avatar
 
Join Date: Sep 2007
Location: Eastern Ky
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Ok im going to try the cps Does it have to be a ford or has anyone tryed one of the auto parts brands feed back thanks.
powerplant is offline  
post #8 of 12 Old 11-21-2007, 03:41 AM Thread Starter
Compression Ignition Addict
 
powerplant's Avatar
 
Join Date: Sep 2007
Location: Eastern Ky
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
powerplant is offline  
post #9 of 12 Old 11-22-2007, 06:44 AM
Member
 
sbond's Avatar
 
Join Date: Nov 2007
Location: East Tennessee
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have replaced mine twice the first time with one from auto parts store it lasted about two years the second one is a ford brand it has been in about 9 months so far.

sbond

1997 PSD 4x4 extended cab long wheelbase
sbond is offline  
post #10 of 12 Old 11-22-2007, 12:43 PM Thread Starter
Compression Ignition Addict
 
powerplant's Avatar
 
Join Date: Sep 2007
Location: Eastern Ky
Posts: 279
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I put the ford replacement in it last night seems fine for moment. _____________________
powerplant is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome