Stalling Issues, PLEASE HELP - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-02-2013, 04:05 PM
Powerstroke.org Rookie
 

Join Date: Jan 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Stalling Issues, PLEASE HELP

Well I guess I will start two weeks ago, actually before that. After 344,000 miles, stock trans and 4 different tuners & chips (different story) the truck was finally ready for new injectors. The local Ford dealership put in remanufactured injectors because "That's all you can get", but whatever they worked and everything was great until a week and a half later. Driving early in the morning, after letting the truck warm up like everyday I began to drive away. After I was about 3 miles from my house, I was climbing a very small hill at about 30 mph, coasting really, then all of a sudden the truck shut off and the battery light let came on. Came up to the stop sign in neutral and then put in park and it started right up. Called my dad and switched trucks with him for the day. He took it to the dealership and they replaced the fuel sensor that had previously gone out years prior. Everything seemed fine until today. After getting off the highway I once again let off the gas and coasted up to a stop sign where the engine once again shut off. This time just as last the battery light came on and it started right up just as the last, but this time the RPMs started going crazy and the truck shut off again after about 30 feet. Sitting in the middle of a boulevard wasn't very enticing so I turned my tuner to stock mode (was in Daily about 75+) (TS Chip with TSD Tunes), and was able to pull it into the median. I waited about 25 min for my dad to come and the truck started right up and I pulled it out of the median and onto a rode leading into a theme park. Once again switched with my dad and he drove it home with no problem in stock and Daily mode once again. I drove around and did my business today and was on the phone with TSD multiple times and am going to drop it off tomorrow. But I did end up driving the truck another 20 miles round trip with no problem. I don't know what could be wrong, bad injectors, bad fuel pump, bad installation on the injectors, tuning issues?

The truck is a 1999.5 F-350 with exhaust and tunes to my knowledge. Can't think of anything else really done. Any help on this? Thanks

Parker
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-02-2013, 04:25 PM
Powerstroke.org Rookie
 

Join Date: Jun 2011
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like a cam sensor to me. thats where i would start anyway.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:04 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors