2000 7.3 has no low end power - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 12-20-2012, 09:27 PM Thread Starter
Powerstroke.org Rookie
 
nate8809's Avatar
 
Join Date: Apr 2010
Location: Lubbock
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
2000 7.3 has no low end power

I ended up blowing the motor in my truck a couple years back when I put a edge evolution on it and kept it in race mode all the time! Well anyways I had a shop here in Lubbock put a used motor out of a 2002 ambulance in it! The only thing is they used my turbo off my old motor which is fine it ran awesome after I got it back and has until recently! It doesn't burn or leak oil! Just rebuilt the turbo today noticed it had a bad compressor fan so I figured that may have something to do with it having Low end power like hardly none won't even break the tires loose! Runs fine at highway speeds just sluggish to get there! I know its time for a new truck just love my 7.3! So just looking for some other suggestions or ideas
nate8809 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 12-20-2012, 10:25 PM
Powerstroke.org Sponsor
 
Justin@DP-Tuner's Avatar
 
Join Date: Nov 2012
Location: Oakdale, CA
Posts: 1,331
Thanks: 2
Thanked 47 Times in 46 Posts
Mentioned: 2 Post(s)
Quoted: 39 Post(s)
Feedback Score: 0 reviews
Do you have any modifications done to it or is it completely stock?

DP-Tuner
For Your Tuning Needs

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Like us on
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!

Justin Bochmann
Sales and Technical Support
828-221-0076 ext.804

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Justin@DP-Tuner is offline  
post #3 of 3 Old 12-21-2012, 07:27 AM Thread Starter
Powerstroke.org Rookie
 
nate8809's Avatar
 
Join Date: Apr 2010
Location: Lubbock
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Has 4" turbo back exhaust (straight pipe) and a 50hp bully dog chip that's been in it since it was brand new! I took it out when I put the edge on it! But after I blew the motor I sold the edge and just put the bully dog chip back in!

Last edited by nate8809; 12-21-2012 at 07:33 AM.
nate8809 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome