HELP! 99.5 Pstroke is running strange - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-30-2012, 06:52 PM
Member
 

Join Date: Nov 2008
Location: Evansville, Indiana
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Sgt. Stroker Send a message via Skype™ to Sgt. Stroker
HELP! 99.5 Pstroke is running strange

It was in the mid 50s today so I went out started my truck and let it warm up while I got my daughter dressed. 15 mins later I load my daughter and self into truck and go down the road. Power is fine, throttle response is good, and then all of a sudden I go over some railroad tracks (not fast or hard) let off the go pedal and press it again and there is no power and service engine soon light comes on.

It starts up almost normal except for a awful noise that it makes as it idles...

there is NO white smoke and its almost like a heavy LOBE sound.

I want to say its a bad injector but I was wanting a few more opinions from here.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-01-2012, 06:01 PM
Member
 

Join Date: Nov 2008
Location: Evansville, Indiana
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Sgt. Stroker Send a message via Skype™ to Sgt. Stroker
a diesel mech. has told me its a "dead miss" bad injector
Reply With Quote Quick reply to this message
  #3  
Old 11-01-2012, 06:22 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2012
Location: New Port Richey, FL
Posts: 98
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ya, that's the only thing I could think of that would cause that
Reply With Quote Quick reply to this message
  #4  
Old 11-01-2012, 06:27 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,059
Thanks: 0
Thanked 12 Times in 12 Posts
Feedback Score: 0 reviews
Check the UVCH.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:04 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors