HELP! 99.5 Pstroke is running strange - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-30-2012, 06:52 PM Thread Starter
Member
 
Sgt. Stroker's Avatar
 
Join Date: Nov 2008
Location: Evansville, Indiana
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Sgt. Stroker Send a message via Skype™ to Sgt. Stroker
HELP! 99.5 Pstroke is running strange

It was in the mid 50s today so I went out started my truck and let it warm up while I got my daughter dressed. 15 mins later I load my daughter and self into truck and go down the road. Power is fine, throttle response is good, and then all of a sudden I go over some railroad tracks (not fast or hard) let off the go pedal and press it again and there is no power and service engine soon light comes on.

It starts up almost normal except for a awful noise that it makes as it idles...

there is NO white smoke and its almost like a heavy LOBE sound.

I want to say its a bad injector but I was wanting a few more opinions from here.

1999 F-250
TS 4 Pos Chip(50-75-100-140)
AFE air intake with K&N filter
5" Exhaust
3 Pillar pod (Pyro, EGT, Boost)
Sgt. Stroker is offline  
post #2 of 4 Old 11-01-2012, 06:01 PM Thread Starter
Member
 
Sgt. Stroker's Avatar
 
Join Date: Nov 2008
Location: Evansville, Indiana
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Sgt. Stroker Send a message via Skype™ to Sgt. Stroker
a diesel mech. has told me its a "dead miss" bad injector

1999 F-250
TS 4 Pos Chip(50-75-100-140)
AFE air intake with K&N filter
5" Exhaust
3 Pillar pod (Pyro, EGT, Boost)
Sgt. Stroker is offline  
post #3 of 4 Old 11-01-2012, 06:22 PM
Powerstroke.org Fanatic
 
Join Date: Oct 2012
Location: New Port Richey, FL
Posts: 98
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ya, that's the only thing I could think of that would cause that
gulfstarfishing is offline  
post #4 of 4 Old 11-01-2012, 06:27 PM
Compression Ignition Addict
 
jesilvas's Avatar
 
Join Date: Feb 2009
Location: Nacogdoches, TX
Posts: 11,148
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 27 Times in 25 Posts
Feedback Score: 0 reviews
Check the UVCH.



2000 F-350 Lariat Super Duty, Dually, CCLB, 7.3L
4R100, 2wd
330,000 + miles
jesilvas is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome