lights flickering and radio goes off, etc... - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-16-2012, 02:12 AM Thread Starter
Powerstroke.org Rookie
 
boomer75's Avatar
 
Join Date: Sep 2008
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
lights flickering and radio goes off, etc...

I have a 2000 7.3 with 180k, a couple weeks ago my battery light came on and with no codes found, it went off a couple days later. So this morning I go out at 4:30 and start going down the road, all of a sudden the radio shuts off and the headlights start flickering like crazy. radio comes back on and I try to pull away from stop sign and truck doesnt want to move. Hesitates and then finally struggles its way into first and then second. In second ran fine. Got back home and while sitting still, speedo jumping up and down and lights still flickering. shut off and when I turned key back on, the wipers came on and my interior lights starting blinking and I heard clicking. I thought battery but why would I have lights? Any ideas would be great.

Thanks
boomer75 is offline  
post #2 of 4 Old 10-16-2012, 08:54 PM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Thanks: 0
Thanked 20 Times in 20 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
did it just rain?

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
post #3 of 4 Old 10-18-2012, 07:48 AM
Member
 
Join Date: Sep 2012
Posts: 72
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Check the electrical plug on top of the alternator make sure it's snapped in
kyler is offline  
post #4 of 4 Old 10-30-2012, 04:59 PM
Powerstroke.org Fanatic
 
Join Date: Apr 2012
Location: Fergus Falls
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
bad batteries, or bad alternator. Mine did this when my alternator quit on me. I was idling on the side of the road, waiting for a police officer and my tuner started beeping like crazy!! then my overdrive light started blinking crazy and lights went really dim, I could rev the motor and the lights would get brighter with the more rpms. Shut the motor off, couldn't get it started again immediately after I shut off the motor. Check the alternator, have the batteries tested. Make sure the connections are tight on the alternator and on the battery cables.

'01 7.3L PSD SCLB
Rubber:Ballistic Jester 18x9, 325/65/18 Falken Wildpeak A/T's << LOVE THEM!!
Motor:CCV mod, Zoodad mod, Edge Evolution CTS, Coolant Filter, Cat ELC, Dual Optima Yellowtop Batteries, 6697 mod
Suspension: Polyurethane sway bar link kit, 6" lift
CLICK TO SEE FOR SALE ITEMS!

My Build Thread

Naterenfo1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome