Turbo prob. Need help!! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 3 Old 09-23-2012, 01:49 PM Thread Starter
Member
 
Join Date: Jul 2012
Location: the. colony
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo prob. Need help!!

Recently i noticed that i wasnt getting much power with accelleration. I noticed i was only getting 15 boost. I took my turbo housing off to inspect it all.

When i got it off i noticed on the fairly new wicked wheel it was not set all the way in on the turbo and the fins had some wear on them. The housing had some scoring from the impeller. Im pretty sure the ww is toast but would like to know yalls thoughts. Also id like to know i my housing is still ok to use. Would it be better to use the stock impeller i have even though it has some knicks in it?

I dont understand how the ww could back out of its place in the turbo to make itself rub on the housing.

Need help on what needs to be done to get my truck back in working order.
Thanks!

Im going to try and post pics but im not really sure how to do it on my phone but i can email pics to anyonr that is willing to help.






2001 powerstroke, edge evolution cs, D.I.Y napa fliter intake system, mbrp 5" exhaust, wicked wheel, 4 inch lift on 35".
BoarKilla24 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-23-2012, 01:51 PM Thread Starter
Member
 
Join Date: Jul 2012
Location: the. colony
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews

2001 powerstroke, edge evolution cs, D.I.Y napa fliter intake system, mbrp 5" exhaust, wicked wheel, 4 inch lift on 35".
BoarKilla24 is offline  
post #3 of 3 Old 09-23-2012, 09:05 PM
Compression Ignition Addict
 
timmyboy76's Avatar
 
Join Date: Aug 2010
Posts: 1,891
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 20 Times in 20 Posts
Feedback Score: 0 reviews
think your turbo needs rebuilding. The "setting" of the wheel looks about right...3/16-1/4in shaft protruding thru wheel..(i messed my first one up, wheel was flush with shaft, and a few miles down road..BAM.) Rebuild kits are 60-80 buks, and easy to do. Theres threads/links on how-tos.

99.5 x-cab 7.3l, 6spd, 161k miles.....
timmyboy76 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome